ステップ 1 |
enable
|
|
ステップ 2 |
configure terminal
Switch# configure terminal
|
グローバル コンフィギュレーション モードを開始します。
|
ステップ 3 |
ip access-list access-list-name
Switch(config)# ip access-list acl1
|
アクセス リストを定義し、アクセス リスト コンフィギュレーション モードを開始します。
|
ステップ 4 |
permit protocol source source-wildcard any
Switch(config-acl)# permit ip 10.111.11.0/24 any
|
条件に一致するトラフィックを許可する条件をIPアクセスリストに設定します。
|
ステップ 5 |
deny protocol source source-wildcard any
Switch(config-acl)# deny udp 10.111.11.100/32 any
|
ネットワークにパケットが入るのを拒否する IP アクセス リストの条件を設定します。
deny ルールは permit として扱われ、拒否ルールに記載された条件に一致するパケットは NAT 変換されずに転送されます。
|
ステップ 6 |
exit
|
アクセスリスト コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。
|
ステップ 7 |
ip nat inside source list access-list-name interface type number overload
Switch(config)# ip nat inside source list acl1 interface ethernet 1/1 overload
|
ステップ 3 で定義したアクセス リストを指定して、ダイナミック送信元変換を設定します。
|
ステップ 8 |
interface type number
Switch(config)# interface ethernet 1/4
|
インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。
|
ステップ 9 |
ip address ip-address mask
Switch(config-if)# ip address 10.111.11.39 255.255.255.0
|
インターフェイスのプライマリ IP アドレスを設定します。
|
ステップ 10 |
ip nat inside
Switch(config-if)# ip nat inside
|
NAT の対象である内部ネットワークにインターフェイスを接続します。
|
ステップ 11 |
exit
|
インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。
|
ステップ 12 |
interface type number
Switch(config)# interface ethernet 1/1
|
インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。
|
ステップ 13 |
ip address ip-address mask
Switch(config-if)# ip address 172.16.232.182 255.255.255.240
|
インターフェイスのプライマリ IP アドレスを設定します。
|
ステップ 14 |
ip nat outside
Switch(config-if)# ip nat outside
|
|
ステップ 15 |
exit
|
インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。
|
ステップ 16 |
ip nat translation tcp-timeout seconds
Switch(config)# ip nat translation tcp-timeout 50000
|
TCP ベースのダイナミック NAT エントリのタイムアウト値を指定します。
|
ステップ 17 |
ip nat translation max-entries [all-host] number-of-entries
Switch(config)# ip nat translation max-entries 300
|
ダイナミックNAT変換の最大数を指定します。エントリの数は1〜1023です。
all-host キーワードは、この変換制限をすべてのホストに適用します。ホストあたりのエントリ数は 1 〜 1023 です。
|
ステップ 18 |
ip nat translation udp-timeout seconds
Switch(config)# ip nat translation udp-timeout 45000
|
UDPベースのダイナミックNATエントリのタイムアウト値を指定します。
|
ステップ 19 |
ip nat translation timeout seconds
switch(config)# ip nat translation timeout 13000
|
ダイナミック NAT 変換のタイムアウト値を指定します。
|
ステップ 20 |
ip nat translation syn-timeout {seconds | never}
switch(config)# ip nat translation syn-timeout 20
|
SYN 要求を送信するが SYN-ACK 応答を受信しない TCP データのパケットタイムアウト値を指定します。
タイムアウト値の範囲は、1 ~ 172800 秒です。デフォルト値は 60 秒です。
never キーワードは、SYN タイマーが実行されないことを指定します。
|
ステップ 21 |
ip nat translation finrst-timeout {seconds | never}
switch(config)# ip nat translation finrst-timeout 30
|
終了(FIN)パケットまたはリセット(RST)パケットを受信して接続が終了したときのフローエントリのタイムアウト値を指定します。RSTパケットとFINパケットの両方の動作を設定するには、同じキーワードを使用します。
タイムアウト値の範囲は、1 ~ 172800 秒です。デフォルト値は 60 秒です。
never キーワードは、FIN または RST タイマーが実行されないことを指定します。
|
ステップ 22 |
end
|
グローバル コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。
|