Configuration on
router 1:
key chain cisco
key 1
key-string bfd
!
segment-routing mpls
!
set-attributes
address-family ipv4
sr-label-preferred
exit-address-family
!
global-block 20000 30000
!
connected-prefix-sid-map
address-family ipv4
21.21.21.21/32 index 2222 range 1
22.22.22.22/32 index 2223 range 1
23.23.23.23/32 index 2224 range 1
exit-address-family
!
bfd-template single-hop TEST
interval min-tx 500 min-rx 500 multiplier 3
authentication md5 keychain cisco
interface Loopback0
ip address 21.21.21.21 255.255.255.255
ip router isis 1
ip ospf 1 area 0
!
interface Loopback1
ip address 22.22.22.22 255.255.255.255
ip router isis 1
ip ospf 1 area 0
!
interface Loopback2
ip address 23.23.23.23 255.255.255.255
ip router isis 1
ip ospf 1 area 0
!
interface Port-channel10
ip unnumbered Loopback1 poll point-to-point
no ip redirects
ip router isis 1
ip ospf network point-to-point
ip ospf bfd
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
bfd template TEST
isis network point-to-point
!
interface GigabitEthernet0/0/3
ip unnumbered Loopback0 poll point-to-point
no ip redirects
ip router isis 1
ip ospf network point-to-point
ip ospf bfd
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
bfd interval 50 min_rx 50 multiplier 3
isis network point-to-point
!
router ospf 1
router-id 21.21.21.21
segment-routing mpls
segment-routing prefix-sid-map advertise-local
fast-reroute per-prefix enable prefix-priority low
fast-reroute per-prefix ti-lfa area 0
fast-reroute keep-all-paths
bfd all-interfaces strict-mode
!
router isis 1
net 49.0001.0000.0000.0000.000a.00
is-type level-2-only
metric-style wide
log-adjacency-changes
segment-routing mpls
segment-routing prefix-sid-map advertise-local
fast-reroute per-prefix level-2 all
fast-reroute ti-lfa level-2
bfd all-interfaces
!
Configuration on
router 2:
key chain cisco
key 1
key-string bfd
!
segment-routing mpls
!
set-attributes
address-family ipv4
sr-label-preferred
exit-address-family
!
global-block 20000 30000
!
connected-prefix-sid-map
address-family ipv4
10.0.0.1/32 index 1111 range 1
2.2.2.2/32 index 1112 range 1
3.3.3.3/32 index 1113 range 1
exit-address-family
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
ip router isis 1
ip ospf 1 area 0
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
ip router isis 1
ip ospf 1 area 0
!
interface Loopback2
ip address 3.3.3.3 255.255.255.255
ip router isis 1
ip ospf 1 area 0
!
interface Port-channel10
ip unnumbered Loopback2 poll point-to-point
no ip redirects
ip router isis 1
ip ospf network point-to-point
ip ospf bfd
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
bfd template TEST
isis network point-to-point
!
interface GigabitEthernet0/0/0
ip unnumbered Loopback0 poll point-to-point
no ip redirects
ip router isis 1
ip ospf network point-to-point
ip ospf bfd
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
bfd interval 50 min_rx 50 multiplier 3
no bfd echo
isis network point-to-point
!
router ospf 1
router-id 10.0.0.1
segment-routing mpls
segment-routing prefix-sid-map advertise-local
fast-reroute per-prefix enable prefix-priority low
fast-reroute per-prefix ti-lfa area 0
fast-reroute keep-all-paths
bfd all-interfaces strict-mode
!
router isis 1
net 49.0001.0000.0000.0000.000b.00
is-type level-2-only
metric-style wide
log-adjacency-changes
segment-routing mpls
segment-routing prefix-sid-map advertise-local
fast-reroute per-prefix level-2 all
fast-reroute ti-lfa level-2
bfd all-interfaces
!
sh bfd neighbors
IPv4 Sessions
NeighAddr LD/RD RH/RS State Int
11.11.11.11 1/2 Up Up Gi0/0/3
12.12.12.12 1026/1025 Up Up Gi0/0/4
13.13.13.13 2/1 Up Up BD111
21.21.21.21 3/1 Up Up Gi0/0/0
22.22.22.22 1025/1025 Up Up Po10
BGL-PEGASUS#
sh bfd neighbors detail
IPv4 Sessions
NeighAddr LD/RD RH/RS State Int
11.11.11.11 1/2 Up Up Gi0/0/3
Session state is UP and not using echo function.
Session Host: Hardware
OurAddr: 10.0.0.1
Handle: 3
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 50000, Multiplier: 3
Received MinRxInt: 50000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 50(0)
Rx Count: 2392
Tx Count: 2413
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF CEF ISIS FRR
Uptime: 00:01:46
Last packet: Version: 1 - Diagnostic: 0
State bit: Up - Demand bit: 0
Poll bit: 0 - Final bit: 0
C bit: 1
Multiplier: 3 - Length: 24
My Discr.: 2 - Your Discr.: 1
Min tx interval: 50000 - Min rx interval: 50000
Min Echo interval: 50000
IPv4 Sessions
NeighAddr LD/RD RH/RS State Int
12.12.12.12 1026/1025 Up Up Gi0/0/4
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 2.2.2.2
Handle: 4
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 500000, MinRxInt: 500000, Multiplier: 3
Received MinRxInt: 500000, Received Multiplier: 3
Holddown (hits): 1296(0), Hello (hits): 500(331)
Rx Count: 332, Rx Interval (ms) min/max/avg: 1/504/440 last: 204 ms ago
Tx Count: 332, Tx Interval (ms) min/max/avg: 1/504/439 last: 320 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF CEF FRR ISIS
Template: TEST
Authentication(Type/Keychain): md5/cisco
last_tx_auth_seq: 4 last_rx_auth_seq 6
Uptime: 00:02:25
Last packet: Version: 1 - Diagnostic: 0
State bit: Up - Demand bit: 0
Poll bit: 0 - Final bit: 0
C bit: 0
Multiplier: 3 - Length: 48
My Discr.: 1025 - Your Discr.: 1026
Min tx interval: 500000 - Min rx interval: 500000
Min Echo interval: 0
IPv4 Sessions
NeighAddr LD/RD RH/RS State Int
13.13.13.13 2/1 Up Up BD111
Session state is UP and not using echo function.
Session Host: Hardware
OurAddr: 3.3.3.3
Handle: 5
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 300000, MinRxInt: 300000, Multiplier: 3
Received MinRxInt: 300000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 300(0)
Rx Count: 502
Tx Count: 504
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF CEF FRR ISIS
Uptime: 00:02:22
Last packet: Version: 1 - Diagnostic: 0
State bit: Up - Demand bit: 0
Poll bit: 0 - Final bit: 0
C bit: 1
Multiplier: 3 - Length: 24
My Discr.: 1 - Your Discr.: 2
Min tx interval: 300000 - Min rx interval: 300000
Min Echo interval: 0
IPv4 Sessions
NeighAddr LD/RD RH/RS State Int
21.21.21.21 3/1 Up Up Gi0/0/0
Session state is UP and not using echo function.
Session Host: Hardware
OurAddr: 10.0.0.1
Handle: 1
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 50000, Multiplier: 3
Received MinRxInt: 50000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 50(0)
Rx Count: 4305
Tx Count: 4323
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF CEF ISIS FRR
Uptime: 00:02:59
Last packet: Version: 1 - Diagnostic: 0
State bit: Up - Demand bit: 0
Poll bit: 0 - Final bit: 0
C bit: 1
Multiplier: 3 - Length: 24
My Discr.: 1 - Your Discr.: 3
Min tx interval: 50000 - Min rx interval: 50000
Min Echo interval: 50000
IPv4 Sessions
NeighAddr LD/RD RH/RS State Int
22.22.22.22 1025/1025 Up Up Po10
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 3.3.3.3
Handle: 2
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 500000, MinRxInt: 500000, Multiplier: 3
Received MinRxInt: 500000, Received Multiplier: 3
Holddown (hits): 1232(0), Hello (hits): 500(393)
Rx Count: 393, Rx Interval (ms) min/max/avg: 4/504/440 last: 268 ms ago
Tx Count: 396, Tx Interval (ms) min/max/avg: 4/504/437 last: 268 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: CEF OSPF FRR ISIS
Template: TEST
Authentication(Type/Keychain): md5/cisco
last_tx_auth_seq: 5 last_rx_auth_seq 4
Uptime: 00:02:53
Last packet: Version: 1 - Diagnostic: 0
State bit: Up - Demand bit: 0
Poll bit: 0 - Final bit: 0
C bit: 0
Multiplier: 3 - Length: 48
My Discr.: 1025 - Your Discr.: 1025
Min tx interval: 500000 - Min rx interval: 500000
Min Echo interval: 0