Prerequisites for SSM Channel Based Filtering for Multicast Boundaries
IP multicast is enabled on the device using the tasks described in the "Configuring Basic IP Multicast" module of the IP Multicast: PIM Configuration Guide.
The documentation set for this product strives to use bias-free language. For the purposes of this documentation set, bias-free is defined as language that does not imply discrimination based on age, disability, gender, racial identity, ethnic identity, sexual orientation, socioeconomic status, and intersectionality. Exceptions may be present in the documentation due to language that is hardcoded in the user interfaces of the product software, language used based on RFP documentation, or language that is used by a referenced third-party product. Learn more about how Cisco is using Inclusive Language.
The SSM Channel Based Filtering for Multicast Boundaries feature enables the user to apply filtering policies based on Source Specific Multicast (SSM) channels for Source and Group (S,G) addresses, which is a combination of source and destination IP addresses.
IP multicast is enabled on the device using the tasks described in the "Configuring Basic IP Multicast" module of the IP Multicast: PIM Configuration Guide.
The SSM Channel Based Filtering for Multicast Boundaries feature expands the ip multicast boundary command for control plane filtering support. More than one ip multicast boundary command can be applied to an interface.
The following rules govern the ip multicast boundary command:
One instance of the in and out keywords can be configured on an interface.
The in and out keywords can be used for standard or extended access lists.
Only standard access lists are permitted with the use of the filter-autorp keyword or no keyword.
A maximum of three instances of a command will be allowed on an interface: one instance of in , one instance of out , and one instance of filter-autorp or no keyword.
When multiple instances of the command are used, the filtering will be cumulative. If a boundary statement with no keyword exists with a boundary statement with the in keyword, both access lists will be applied on the in direction and a match on either one will be sufficient.
All instances of the command apply to both control and data plane traffic.
Protocol information on the extended access list is parsed to allow reuse and filtering for consistency. An (S,G) operation will be filtered by an extended access list under all conditions stated above for keywords if the access list filters (S,G) traffic for all protocols.
This feature allows input on the source interface.
The access control capabilities are the same for SSM and Any Source Multicast (ASM).
Command or Action | Purpose | |||
---|---|---|---|---|
Step 1 |
enable Example:
|
Enables privileged EXEC mode. |
||
Step 2 |
configure terminal Example:
|
Enters global configuration mode. |
||
Step 3 |
ip access-list {standard | extended } access -list -name Example:
|
Configures the standard or extended access list. |
||
Step 4 |
permit protocol host address host address Example:
|
Permits specified ip host traffic. |
||
Step 5 |
deny protocol host address host address Example:
|
Denies specified multicast ip group and source traffic. |
||
Step 6 |
Repeat Step 4 or Step 5 as needed. |
Permits and denies specified host and source traffic. |
||
Step 7 |
interface type interface-number port -number Example:
|
Enables interface configuration mode. |
||
Step 8 |
ip multicast boundary access-list-name [in | out | filter-autorp ] Example:
|
|
The following example permits outgoing traffic for (181.1.2.201, 232.1.1.1) and (181.1.2.202, 232.1.1.1) and denies all other (S,G)s.
configure terminal
ip access-list extended acc_grp1
permit ip host 0.0.0.0 232.1.1.1 0.0.0.255
permit ip host 181.1.2.201 host 232.1.1.1
permit udp host 181.1.2.202 host 232.1.1.1
permit ip host 181.1.2.202 host 232.1.1.1
deny igmp host 181.2.3.303 host 232.1.1.1
interface gigabitethernet 2/3/0
ip multicast boundary acc_grp1 out
The following example permits outgoing traffic for (192.168.2.201, 232.1.1.5) and 192.168.2.202, 232.1.1.5).
configure terminal
ip access-list extended acc_grp6
permit ip host 0.0.0.0 232.1.1.1 5.0.0.255
deny udp host 192.168.2.201 host 232.1.1.5
permit ip host 192.168.2.201 host 232.1.1.5
deny pim host 192.168.2.201 host 232.1.1.5
permit ip host 192.168.2.202 host 232.1.1.5
deny igmp host 192.2.3.303 host 232.1.1.1
interface gigabitethernet 2/3/0
ip multicast boundary acc_grp6 out
The following example denies a group-range that is announced by the candidate RP. Because the group range is denied, no pim auto-rp mappings are created.
configure terminal
ip access-list standard acc_grp10
deny 225.0.0.0 0.255.255.255
permit any
access-list extended acc_grp12
permit pim host 181.1.2.201 host 232.1.1.8
deny udp host 181.1.2.201 host 232.1.1.8
permit pim host 181.1.2.203 0.0.0.255 host 227.7.7.7
permit ip host 0.0.0.0 host 227.7.7.7
permit ip 181.1.2.203 0.0.0.255 host 227.7.7.7
permit ip host 181.1.2.201 host 232.1.1.7
ip access-list extended acc_grp13
deny ip host 181.1.2.201 host 232.1.1.8
permit ip any any
interface gigabitethernet 2/3/0
ip multicast boundary acc_grp10 filter-autorp
ip multicast boundary acc_grp12 out
ip multicast boundary acc_grp13 in
Related Topic |
Document Title |
---|---|
Cisco IOS IP Multicast commands |
MIB |
MIBs Link |
---|---|
No new or modified MIBs are supported by this feature, and support for existing standards has not been modified by this feature. |
To locate and download MIBs for selected platforms, Cisco IOS XE releases, and feature sets, use Cisco MIB Locator found at the following URL: |
Description |
Link |
---|---|
The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password. |
The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.
Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to https://cfnng.cisco.com/. An account on Cisco.com is not required.
Feature Name |
Releases |
Feature Information |
---|---|---|
SSM Channel Based Filtering for Multicast Boundaries |
Cisco IOS XE Release 2.1 |
The SSM Channel Based Filtering for Multicast Boundaries feature enables the user to apply filtering policies based on Source Specific Multicast (SSM) channels for Source and Group (S,G) addresses, which is a combination of source and destination IP addresses. The following command was introduced or modified:
|