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. B3| objects > Object Management > PKI > Cert Enroliment 3% — T Add Cert Enroliment,



Add Cert Enroliment (7]

Name*
vpntestbbed.cisco.com
Description
|
CA Information Certificate Parameters Key Revocation

Enrollment Type: | Manual v
[ ] CA Only
Check this option if you do not require an identity certificate fo be created
from this CA
CA Certificate: Ep':“_ Iangreno .. ST2xar
YfPCilB7g

BMAV7Gzdc4VspS6ljirAhbiiaw
dBiQIQmsBeFz9JkF4..b3I8Bo
GN+gMa56Y
lt8unaZgY4l20//on88r5IWJIm

Validation Usage: IPsec Client SSL Client [ | SSL Server
| | Skip Check for CA flag in basic constraints of the CA Certificate

|| Allow Overrides

Cancel Save

- 1EE Enroliment Type AR BE L BB RBENC(CA)BE (AREEBCSRIEE ) .
- REBEEDFE—EEBIIERE custom FoDN WIEBFASENEA , S0 -



Add Cert Enroliment Q

Name*
vpntesthbed.cisco.com
Description
CA Information Certificate Parameters Key Revocation

Include FQDN: Use Device Hostname as FODN

Include Device's IP Address: 10.88.243.123

Common Mame (CN): vpntestbed.cisco.com

Organization Unit (OU): TAC

Organization (0): | Mexico

Locality (L): | MX

State (ST): CDMX

Country Code (C): | MX

Email (E): I tac@cisco.com

Include Device's Serial Number | |

|| Allow Overrides

Cancel Save

CEE=EEE L EBIE keyTyped , BEBZBANK/D, HRRSA , &2 5204814,
. :Ef - Tﬁ'ﬁ-fﬂ?gﬂ Devices > Certificates > Add > New Certificate.
. %&EE Device, *u-F Cert Enrollment ﬁ%f@ﬁ“ﬁ“ﬁﬁ%%1§% , E_T Add:



Add New Certificate (7]

Add a new certificate to the device using cert enrollment object which is used to
generate CA and identify certificate.

Device®:
FTD v

Cert Enrollment®:

l vpntestbed.cisco.com| v ‘ +

Cert Enrollment Details:

MName: vpntestbed.cisco.com

Bk BEETHBEEEN @ BlR , RE vesWASRCSRERIICAYHZE R, HENE
MAEEHTTPSHREFHY EEBMMEE.

- fCAl Flbaseb4 XM/ ER , RURPBIERES , RABE—T mpon. BLLIRERTIE |, &
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wpntesshod ciseo.com Ginbal Salf-Signed SCA (4D LI ]

b) & RADIUS {7 B 8%

. EHEF Objects > Object Management > RADIUS Server Group > Add RADIUS Server Group.

CEREEBAMEPHUARLAEE | T save:



Edit RADIUS Server

IP Address/Hostname:*

192.168.20.7
Configure DNS at Threat Defense Platform Settings to resolve hostname
Authentication Port:* (1-65535)

1812
Key:*

—
—a
I
an
(9 |
(]
Cad
(9 |

Accounting Port:
1813

Timeout: (1-300) Seconds
10

Connect using:
(® Routing () Specific Interface @

Default: Management/Diagnostic i

Redirect ACL:

- 2B BERIFERNMARESR

Marme

RadiusServer

C)RVPN{E M &2 M bkt




. EE3 Objects > Object Management > Address Pools > Add IPv4 Pools.
-WAEBNEE , TEERG
Name*

I vpn_pool ‘

IPv4 Address Range*
\ 10.72.1.1-10.72.1.150 \

Mask
‘ Specify a netmask in X.X.X.X format ‘

Description

Allow Overrides

. Configure device overrides in the address pool object to
avoid IP address conflicts in case of object is shared across
multiple devices

»  Override (0)

d)EIXMLE BHER

RERRBL TREEERRES  AEREHEHBR.

. EEIJ Server List > Add...

- REFETBBAFQDN, S ERRI[FEHPEFRILATHRE -
[ AnyConnect Profile Editor - VPN
File Help

L VPN | Server List

@ Preferences (Part 1) . .
2 Preferences (Fart 2 Profile: C:AUsers\calo\Documents\Anyconnect_profile.xml

-5 Backup Servers
# Certificate Pinning

Certificate Matching Hostname Host Address User Group Backup Server List  SCEP Maobile Settings Certificate Pins
- B Certificate Enrollment VPM(S5L) vpntestbed.dsco.... - Inherited —
_, Mobile Policy VPM(IPSEC) vpntestbed.cisco.... - Inherited —

- |afl Server List

Mote: it is highly recommended that at least one server be defined in a profile.

. :Ef_-F OK*[I File > Save as...

Add...

Delete

Details




e) L MAnyConnectii

- (ER BB T MpkgiR B
. EE“ Objects > Object Management > VPN > AnyConnect File > Add AnyConnect File.

CRBABRBYRUBEDRIEPKGER |, 28— T save:

Edit AnyConnect File (7]

Mame:*

I Wnyconnectmac4.10 |

File Name:*

| anyconnect-macos-4.10.06079-webdef | | Browse..
File Type:*

| AnyConnect Client Image v |
Description:

| Cancel |

- BRBZHECHNERFEESRBA,
2. B w35 E RN

- B % pevices > VPN > Remote Access > Add a new configuration.

. MEREEINBIZFTDEE :



Targeted Devices and Protocols

This wizard will guide you through the required minimal steps to configure the Remote
Access VPN policy with a new user-defined connection profile.

Mame:*

| Anyconnect_RA |

Description:

VPN Protocols:

SSL
IPsec-IKEv2

Targeted Devices:

Available Devices Selected Devices

| Q_ Search | FTD

FTD

. ‘T:I_: rﬁfﬁﬁlﬁﬁ%.} Z/Fﬁq:' , ﬁl Connection Profile Name , igﬁ Authentication Server ﬂl Address
Pools iﬁ&ZﬁﬁEﬁE@%ﬁ .



Connection Profile:

Connection Profiles specify the tunnel group policies for a VPN connection. These policies pertain to creating the
tunnel itself, how AAA is accomplished and how addresses are assigned. They also include user attributes, which
are defined in group policies.

Connection Profile Name:* | Anyconnect_RA

I @ This name is configured as a connection alias, it can be used to connect to the VPN gateway

Authentication, Authorization & Accounting (AAA):

Specify the method of authentication (AAA, certificates or both), and the AAA servers that will be used for VPN
connections.

Authentication Method: [ AAA Only v l

RadiusServer v l -+
(LOCAL or Realm or RADIUS)
[ Fallback to LOCAL Authentication

Authentication Server:*

Authorization Server: | Use same authentication server | +
(Realm or RADIUS)

Accounting Server: | v | -
(RADIUS)

Client Address Assignment:

Client IP address can be assigned from AAA server, DHCP server and IP address pools. When multiple options are
selected, IP address assignment is tried in the order of AAA server, DHCP server and IP address pool.

] Use AAA Server (Realm or RADIUS only) @
[ ] Use DHCP Servers
Use IP Address Pools

IPvd Address Pools: | vpn_pool

N

IPv6 Address Pools: I

Group Policy:

A group policy is a collection of user-oriented session attributes which are assigned to client when a VPN
connection is established. Select or create a Group Policy object.

Group Policy:* DfitGrpPolicy v | +

Edit Group Policy

. :I"Zf—-F Edit Group Policy EAnyConnectEﬁJ: , EE Client Profile , %?ﬁﬁi—? Save!



Edit Group Policy (7]

Name:*
DfitGrpPolicy

Description:

General AnyConnect Advanced

Profile

AnyConnect profiles contains settings for the VPN client functionality and
Management Profile = optional features. Firewall Threat Defense deploys the profiles during
AnyConnect client connection.

Client Modules

SSL Settings Client Profile:

Connection Settings Anyconnect_profile v | +

Custom Attributes Standalone profile editor can be used to create a new or modify existing

AnyConnect profile. You can download the profile editor from Cisco Software
Download Center.

. ET—EL , #ZEAnyConnectB 1% , REHE—T next.
AnyConnect Client Image

The VPN gateway can automatically download the latest AnyConnect package to the client device when the VPN
connection is initiated. Minimize connection setup time by choosing the appropriate OS for the selected package.

Download AnyConnect Client packages from Cisco Software Download Center.

Show Re-order buttons 4

AnyConnect File Object Name AnyConnect Client Package Name Operating System

Anyconnectmac4.10 anyconnect-macos-4.10.06079-webdeploy... Mac OS v ‘

. 'T:I_:-F_1§%J: s 1&% Network Interface and Device Certificates:



Network Interface for Incoming VPN Access

Select or create an Interface Group or a Security Zone that contains the network interfaces users
will access for VPN connections.

Interface group/Security Zone:* | Outsied v | +

Enable DTLS on member interfaces

A All the devices must have interfaces as part of the Interface Group/Security Zone selected.

Device Certificates

Device certificate (also called Identity certificate) identifies the VPN gateway to the remote access
clients. Select a certificate which is used to authenticate the VPN gateway.

Certificate Enrollment:* vpntestbed.cisco.com v | +

Access Control for VPN Traffic

All decrypted traffic in the VPN tunnel is subjected to the Access Control Policy by default. Select
this option to bypass decrypted traffic from the Access Control Policy.

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)
This option bypasses the Access Control Policy inspection, but VPN filter ACL and
authorization ACL downloaded from AAA server are still applied to VPN traffic.

. BFTEE B LR AR —T Finish A% Deploy:



:
Remote
User

~—0 ® 1.
L ‘ © mm e B
Outside VPN

AnyConnect
Client

Remote Access VPN Policy Configuration

Firepower Management Center will configure an RA VPN Policy with the following settings

Name:
Device Targets:
Connection Profile:
Connection Alias:
AAA:
Authentication Method:
Authentication Server:
Authorization Server:
Accounting Server;
Address Assignment:
Address from AAA:
DHCP Servers:
Address Pools (IPvd):
Address Pools (IPv6):
Group Policy:
AnyConnect Images:
Interface Objects:

Device Certificates:

Anyconnect_RA
FTD
Anyconnect_RA

Anyconnect_RA

AAA Only
RadiusServer (RADIUS)
RadiusServer (RADIUS)

vpn_pool
DMGrpPolicy
Anyconnectmac4.10
Qutsied

vpntestbed.cisco.com

Device Identity Certificate Enrollment

Certificate enrollment object 'vpntestbed.cisco.com’ is not installed on one or more
targeted devices. Certificate installation will be initiated on the targeted devices on
finishing the wizard. Go to the Certificates page to check the status of the installation.
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HRERIFTD , KT EFARBIESR , BABONBNEADNSEBHIPfU, REEAREFEL

RADIUSTAIRZRFHBIREA , W HEER LHATHRHA. ZEAnyConnecti®

AnyConnect{f B P BRI bk , AREIE—T connect.

B 5l

FTDERITX#E , BASALTH :

Device

5
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Additional Configuration Requirements

After the wizard completes, the following
configuration needs to be completed for VPN to
work on all device targets.

© Access Control Policy Update

An Access Control rule must be defined to allow
VPN traffic on all targeted devices.

© NAT Exemption

If MAT is enabled on the targeted devices, you
must define a NAT Policy to exempt VPN traffic.

@ DNS Configuration

To resolve hostname specified in AAA Servers
or CA Servers, configure DNS using FlexConfig
Policy on the targeted devices.

' Port Configuration

SSL will be enabled on port 443.

IPsec-IKEv2 uses port 500 and Client Services
will be enabled on port 443 for Anyconnect
image download.NAT-Traversal will be enabled
by default and will use port 4500.

Please ensure that these ports are not used in
NAT Policy or other services before deploying
the configuration.

A Network Interface Configuration

Make sure to add interface from targeted
devices to SecurityZone object 'Outsied’

SR EHERE | EREFMAnyConnectiH ERBIFTDEE,

Firepower Threat Defense 6.2.3E RRAF X IFTERADIUSTRIRREEFEENEH, EHBBE

2B EEE
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https://cdetsng.cisco.com/summary/#/defect/CSCvq87631
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. AnyConnectt&# ( NAM, Hostscan, AMP Enabler, SBL, Umbrella, Web Security® ) —
FERRIE R T Z#DART(AMP EnablerflUmbrellafy i858 IhAE : BRIEEERID CSCvs03562F B R
§£221D CSCvs0642).

. TACACS. Kerberos ( KCD& 17527 MIRSA SDI )

- BERAE

REXEEH

EREBERT , sysopt connection permit- vpnlﬁlﬁ*&f’fﬁﬁ o EREBEA/EEAFREBIANTNE LU R TR
EFEBE ?"'“%'J%ﬂlﬁo BRI T FRIBIEES A ?"'“%'Jiﬁ RIVEAFFVPNRE |, BMMREHXREER
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- AARERFEERAENFERELZRA ( ECHoHESR ) o % Devices > Device Management >

Edit > Routing > Static Route j]?lgﬂi Add route
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Add Static Route Configuration 7

Type: @ IPvd () IPvB
Interface*
\ Nullo v \

(Interface starting with this icon [ signifies it is available for route leak)

Available Network . Selected Network

Q, Search ‘ Add ‘ objvpnusers ™
any-ipvd
FMC
GW

IPvd-Benchmark-Tests
IPvd-Link-Local

IPvd-Multicast

Gateway*

Metric:
1

(1 -254)

Tunneled: [ | (Used only for default Route)

Route Tracking:

CETR, EVPNEZRKR LN E LEBAURPF, EEHLLIE |, FEMZ Devices > Device

Management > Edit > Interfaces > Edit > Advanced > Security Configuration > Enable Anti Spoofing.



Edit Physical Interface L]

General IPwd IPv6 Path Monitoring Hardware Configuration Manager Access Advanced
I

Information ARP Security Configuration

Enable Anti Spoofing:
Allow Full Fragment Reassembly:

Override Default Fragment Setting:

‘ Cancel |m

EFEAEESE  SERARTAZXTERAELEIN2MNER, FBRIRA NP EMBRERIPH IR
ARESWURFPERE, EREMNEIR | BHITUUATEE : Anti-Spoofingia 2 B TEFirepower & & fh &
BREREBESIE,

b)RXA sysopt connection permit-vpn 1 IH

. ﬁﬂii§ﬁ623#&§2E%Wi$ , EJJE“’XIEEEFH @gﬁii‘fﬂ?*}l?fﬁﬁ'flﬁ Devices > VPN > Remote

Access > VPN Profile > Access Interfaces.

Access Control for VPN Traffic

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)
Decrypted traffic is subjected to Access Control Policy by default. This option
bypasses the inspection, but VPN Filter ACL and authorization ACL downloaded from

AAA server are still applied to VPN traffic.

- HA6.2.3 2 BTHIRRAS |, 5588 ZI objects > Object Management > FlexConfig > Text Object > Add Text Object.
- B NAHREE , HIW : vpnSysVarE BB ERBRE sysopt.

. EEU Objects> Object Management > FlexConfig > FlexConfig Object > Add FlexConfig Object.

- 23] FlexConfig fEFACLIEYEI SR  connection permit-vpn.

- BN AR REEIA A Flexconfig CLILEBVET R $vpnsysvar connection permit-vpn. 3 — T save:


/content/en/us/td/docs/security/firepower/622/configuration/guide/fpmc-config-guide-v622/interfaces_for_firepower_threat_defense.html?bookSearch=true#task_34BB9AC8E91946AB847C65FB79D67A5F
/content/en/us/td/docs/security/firepower/622/configuration/guide/fpmc-config-guide-v622/interfaces_for_firepower_threat_defense.html?bookSearch=true#task_34BB9AC8E91946AB847C65FB79D67A5F

Insert Text Object Variable

Variable Name: | wpnSysvas
Description: [

Available Objects & Selected Object

[ 4, Search [T vpnSysvar

e ——
[0 repMssBytes

[T tepMssMinimum

[T threat_cetection_statistics

[T vtan_wve_Onily

[T vdtan_Port_and_Nve
[T vtan_wini

[T weepPassword

. EFH FIexConfigﬁgﬂkp Append WiRFEIHEE Everytime:

Edit FlexConfig Object ? %
Name: | connection_permit-vpn
Description:

Omsern+ | EH | Deploymert: Type:

...................................

Variables E]
vpnSysvar SINGLE sysopt FREEFORM:vpn.. false

[ Save J [ Cancel J

- H Flpevices > FlexConfig ﬂﬁﬁﬁ%‘ﬁﬁﬁmﬁﬁﬁﬁﬁ New Policy H‘iﬂo
. E%ﬁng‘,EﬁE’ﬂ FlexConfig , #E_-F Save.
. %B%MELXEHmsysopt connection permit-vpnﬁ:"%o

BRELZE  BTREAGEEHRKRRERACAENRE. BOHRTLUERAVPNIBRERH
A FEACLRBREMERE.

MREEFRBAVPNEAEZBEBESnont ERREHT , FHIRTACA S E ERIEERID
CSCvg91399,
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