Inleiding
Dit document beschrijft hoe u een probleem kunt oplossen dat wordt veroorzaakt door persistente registratiesleutels bij het installeren of upgraden van Cisco Jabber voor Windows.
Voorwaarden
Vereisten
Cisco raadt u aan kennis te hebben van deze onderwerpen:
- Cisco Jabber voor Windows
- Microsoft Windows versie 7 (besturingssysteem) (32 en 64-bits
- Microsoft Windows versie 10 (besturingssysteem) (32 en 64-bits
Gebruikte componenten
Dit document is niet beperkt tot specifieke hardware- of softwareversies.
De informatie in dit document is gebaseerd op de apparaten in een specifieke laboratoriumomgeving. Alle apparaten die in dit document worden beschreven, hadden een opgeschoonde (standaard)configuratie. Als uw netwerk live is, moet u de potentiële impact van elke opdracht begrijpen.
Probleem
Wanneer u probeert om Cisco Jabber te installeren of upgraden voor Windows versie 9.x of hoger, wordt de poging mislukt en ontvangt u deze foutmelding:
Error 1714. The older version of Cisco Jabber cannot be removed. Contact your technical Support team
Oorzaak
De programma's die via het Microsoft Installer-bestand (MSI) zijn geïnstalleerd, bevatten een onderdeel van de desinstalleer-toets met een Windows-installatiewaarde van één (1). Wanneer de functie Software dit item tegenkomt, herkent het de sleutelnaam en wijzigt het deze. Het zoekt dan naar een sleutel die met de opnieuw geordende Madebuut in deze plaats wordt genoemd:
HKLM > Software > Klassen > Installatieprogramma > Producten
Aangezien de registratiesleutel beschadigd is, moet deze worden verwijderd.
Oplossing
Klik op OK om de Windows-installatieprogramma's te verzamelen; zoek dan het register dat op ARPPR-productie wijst en zie welk register wordt aangetast.
Hier is een voorbeeld van Jabber die weblogs installeert:
MSI (s) (00:68) [13:39:25:865]: Doing action: RemoveExistingProducts
Action 13:39:25: RemoveExistingProducts. Removing applications
Action start 13:39:25: RemoveExistingProducts.
RemoveExistingProducts: Application: {B63FA739-46CF-4270-B903-90F5698EDF39}, Command line: UPGRADINGPRODUCTCODE={F5C0DBF4-2D93-4A73-9AF3-E931AFF8BAF9} CLIENTPROCESSID=13016 CLIENTUILEVEL=0 REMOVE=ALL
MSI (s) (00:24) [13:39:25:880]: Unexpected or missing value (name: 'PackageName', value: '') in key 'HKLM\Software\Classes\Installer\Products\937AF36BFC6407249B30095F96E8FD93\SourceList'
CustomAction returned actual error code 1610 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (00:68) [13:39:25:880]: Note: 1: 1714 2: Cisco Jabber 3: 1610
MSI (c) (D8:B8) [13:39:28:589]: Doing action: setErrorUnknownError
Action 13:39:28: setErrorUnknownError.
Action start 13:39:28: setErrorUnknownError.
MSI (c) (D8:B8) [13:39:28:589]: PROPERTY CHANGE: Modifying ERROR_INSTALL property. Its current value is '0'. Its new value: '4'.
Action ended 13:39:28: setErrorUnknownError. Return value 1.
Error 1714. The older version of Cisco Jabber cannot be removed. Contact your technical support group. System Error 1610.
MSI (s) (00:68) [13:39:28:605]: Product: Cisco Jabber -- Error 1714. The older version of Cisco Jabber cannot be removed. Contact your technical support group. System Error 1610.
Klik vanuit de client op Start > Reken en navigeer naar deze locaties:
HKLM > Software > Klassen > Installatieprogramma > Producten >937AF36BFC6407249B30095F96E8FD93 > SourceList
Verwijdert de toetsen, start de computer opnieuw en start het installatie- of upgradeproces opnieuw.
Opmerking: Er kan administratieve toegang nodig zijn om toegang te krijgen tot de registratiesleutels op de computer.