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Inleiding

Dit document beschrijft een configuratie voor AnyConnect Remote Access VPN op FTD.

Voorwaarden

Vereisten

Cisco raadt kennis van de volgende onderwerpen aan:

- Basis VPN-, TLS- en IKEv2-kennis
- Basisverificatie, autorisatie en accounting (AAA) en RADIUS-kennis
- Ervaring met Firepower Management Center

Gebruikte componenten
De informatie in dit document is gebaseerd op de volgende software- en hardware-versies:

. Cisco FTD 7.2.0
. CiscoVCC 7.2.1



- AnyConnect 4.10

De informatie in dit document is gebaseerd op de apparaten in een specifieke
laboratoriumomgeving. Alle apparaten die in dit document worden beschreven, hadden een
opgeschoonde (standaard)configuratie. Als uw netwerk live is, moet u zorgen dat u de potentiéle
impact van elke opdracht begrijpt.

Achtergrondinformatie

Dit document biedt een configuratievoorbeeld voor Firepower Threat Defence (FTD), versie 7.2.0
en hoger, waarmee externe toegang tot VPN mogelijk is om Transport Layer Security (TLS) en
Internet Key Exchange versie 2 (IKEv2) te gebruiken. Als client kan Cisco AnyConnect worden
gebruikt, wat op meerdere platforms wordt ondersteund.

Configuratie

1. Voorwaarden
Zo gaat u door de wizard Externe toegang in Firepower Management Center:

- Maak een certificaat aan dat wordt gebruikt voor serververificatie.
- Configureer RADIUS- of LDAP-server voor gebruikersverificatie.
- Maak een pool van adressen voor VPN-gebruikers.

- Upload AnyConnect-afbeeldingen voor verschillende platforms.

a) Het SSL-certificaat invoeren

Certificaten zijn essentieel wanneer u AnyConnect configureert. Het certificaat moet de extensie
Alternatieve Naam hebben met DNS-naam en/of IP-adres om fouten in webbrowsers te
voorkomen.

Opmerking: alleen geregistreerde Cisco-gebruikers hebben toegang tot interne tools en
buginformatie.

Er zijn beperkingen voor handmatige inschrijving van certificaten:
- Op FTD hebt u het CA-certificaat nodig voordat u de CSR genereert.

- Indien de MVO extern wordt gegenereerd, kan de handmatige methode niet werken, maar moet
een andere methode worden gebruikt (PKCS12).

Er zijn verschillende methoden om een certificaat op FTD-apparaat te verkrijgen, maar de veilige
en makkelijke manier is om een Certificate Signing Verzoek (CSR) te maken, het te ondertekenen
met een Certificate Authority (CA) en vervolgens een geimporteerd certificaat afgegeven voor
publieke sleutel, die in CSR was. Dit is de manier om dat te doen:

- Ga naar veld oObjects > Object Management > PKI > Cert Enroliment , klik op Cert-inschrijving toevoegen.



Add Cert Enroliment (7]

Name*
vpntestbbed.cisco.com
Description
|
CA Information Certificate Parameters Key Revocation

Enrollment Type: | Manual v
[ ] CA Only
Check this option if you do not require an identity certificate fo be created
from this CA
CA Certificate: Ep':“_ Iangreno .. ST2xar
YfPCilB7g

BMAV7Gzdc4VspS6ljirAhbiiaw
dBiQIQmsBeFz9JkF4..b3I8Bo
GN+gMa56Y
lt8unaZgY4l20//on88r5IWJIm

Validation Usage: IPsec Client SSL Client [ | SSL Server
| | Skip Check for CA flag in basic constraints of the CA Certificate

|| Allow Overrides

| Cancel | Save

- Kiezen Enroliment Type certificaat van de certificeringsinstantie (CA) (het certificaat dat wordt
gebruikt om de CSR te ondertekenen).

- Ga vervolgens naar het tweede tabblad en selecteer custom FQDN en vul alle nodige velden in,
bijvoorbeeld:



Add Cert Enroliment Q

Name*
vpntesthbed.cisco.com
Description
CA Information Certificate Parameters Key Revocation

Include FQDN: Use Device Hostname as FODN

Include Device's IP Address: 10.88.243.123

Common Mame (CN): vpntestbed.cisco.com

Organization Unit (OU): TAC

Organization (0): | Mexico

Locality (L): | MX

State (ST): CDMX

Country Code (C): | MX

Email (E): I tac@cisco.com

Include Device's Serial Number | |

|| Allow Overrides

Cancel Save

- Selecteer in het derde tabblad de optie ey TypeKies naam en grootte. Voor RSA zijn minimaal
2048 bits vereist.

- Klik op Opslaan en ga naar Devices > Certificates > Add > New Certificate.

- Selecteer vervolgens Device, €n Cert Enroliment Selecteer het trustpoint dat u zojuist hebt gemaakt,
klik op Add:



Add New Certificate (7]

Add a new certificate to the device using cert enrollment object which is used to
generate CA and identify certificate.

Device®:
FTD v

Cert Enrollment®:

l vpntestbed.cisco.com| v ‘ +

Cert Enrollment Details:

MName: vpntestbed.cisco.com

- Later, naast de trustpoint naam, klikt u op de "-:3? pictogram, gevolgd ves, en daarna CSR naar
CA kopiéren en ondertekenen. Certificaat moet dezelfde kenmerken hebben als een HTTPS-
server.

- Nadat u het certificaat van CA in base64-formaat hebt ontvangen, selecteert u het van de
schijf en klikt u op import. Als dit lukt, zie je:

=D -

vntesshed.ctsen.com Gicoal Seit-Signed oA (4D tRPCE

b) RADIUS-server configureren

. Ga naar veld Objects > Object Management > RADIUS Server Group > Add RADIUS Server Group.
- Vul de naam in en voeg |IP-adres toe samen met gedeeld geheim, klik op save:



Edit RADIUS Server

IP Address/Hostname:*

192.168.20.7
Configure DNS at Threat Defense Platform Settings to resolve hostname
Authentication Port:* (1-65535)

1812
Key:*

Confirm Key:*

—
—a
I
an
(9 |
(]
Cad
(9 |

Accounting Port:
1813

Timeout: (1-300) Seconds
10

Connect using:
(® Routing () Specific Interface @

Default: Management/Diagnostic i

Redirect ACL:

- Daarna ziet u de server in de lijst:

Marme Value

RadiusServer 1 Server

¢) Maak een pool van adressen voor VPN-gebruikers



.- Ga naar veld objects > Object Management > Address Pools > Add IPv4 Pools.

. Zet de naam en bereik, masker is niet nodig:

Name*

I vpn_pool

IPv4 Address Range*

‘ 10.72.1.1-10.72.1.150

Mask

‘ Specify a netmask in X.X.X.X format

Description

Allow Overrides

. Configure device overrides in the address pool object to
avoid IP address conflicts in case of object is shared across

multiple devices

»  Override (0)

d) XML-profiel maken

- Download de Profile Editor van de Cisco-site en open deze.
- Ga naar veld server List > Add...

- Zet de naam en FQDN van het display. U ziet vermeldingen in de serverlijst:
[ AnyConnect Profile Editor - VPN

File Help
VPN | Server List
@ Preferences (Part 1) . J
Profile: C:AUsers\calo\Documents\Anyconnect_profile.xml

----- -+ Preferences (Part 2)
----- Backup Servers

----- % Certificate Pinning
=0 Certificate Matching
----- Certificate Enrollment

Mobile Policy
----- Server List

Hostname
VPM(S5L)
VPM(IPSEC)

Host Address

vpntestbed.dsco....
vpntestbed.cisco....

User Group

Backup Server List  SCEP
-- Inherited --
- Inherited --

Maobile Settings

Certificate Pins

Mote: it is highly recommended that at least one server be defined in a profile.

. Klik oken File > Save as...

Add...

Delete

Details




e) AnyConnect-afbeeldingen uploaden

- Download pkg-afbeeldingen van de Cisco-site.
. Ga naar veld objects > Object Management > VPN > AnyConnect File > Add AnyConnect File.
- Typ de naam en selecteer PKG-bestand vanaf schijf, klik op save:

Edit AnyConnect File (7]

Mame:*

| Wnyconnectmac4.10 |

File Name:*

| anyconnect-macos-4.10.06079-webdef | | Browse..
File Type:*

| AnyConnect Client Image v |
Description:

Cancel |

- Voeg meer pakketten toe op basis van uw eigen vereisten.

2. Wizard Externe toegang

- Ga naar veld Devices > VPN > Remote Access > Add a new configuration.
- Geef het profiel een naam en selecteer FTD-apparaat:



Targeted Devices and Protocols

This wizard will guide you through the required minimal steps to configure the Remote
Access VPN policy with a new user-defined connection profile.

Mame:*

| Anyconnect_RA |

Description:

VPN Protocols:

SSL
IPsec-IKEv2

Targeted Devices:

Available Devices Selected Devices

| Q_ Search | FTD

FTD

- Typ in de stap Verbindingsprofiel het volgende: Connection Profile Name, selecteert u de
Authentication Server €N Address Pools die U eerder hebt gemaakt:



Connection Profile:

Connection Profiles specify the tunnel group policies for a VPN connection. These policies pertain to creating the
tunnel itself, how AAA is accomplished and how addresses are assigned. They also include user attributes, which
are defined in group policies.

Connection Profile Name:* | Anyconnect_RA

I @ This name is configured as a connection alias, it can be used to connect to the VPN gateway

Authentication, Authorization & Accounting (AAA):

Specify the method of authentication (AAA, certificates or both), and the AAA servers that will be used for VPN
connections.

Authentication Method: [ AAA Only v l

RadiusServer v ] -+
(LOCAL or Realm or RADIUS)
[ Fallback to LOCAL Authentication

Authentication Server:*

Authorization Server: | Use same authentication server | +
(Realm or RADIUS)

Accounting Server: | v | -
(RADIUS)

Client Address Assignment:

Client IP address can be assigned from AAA server, DHCP server and IP address pools. When multiple options are
selected, IP address assignment is tried in the order of AAA server, DHCP server and IP address pool.

] Use AAA Server (Realm or RADIUS only) @

[ ] Use DHCP Servers
Use IP Address Pools

N

IPvd Address Pools: l vpn_pool J
|

IPv6 Address Pools: I

Group Policy:

A group policy is a collection of user-oriented session attributes which are assigned to client when a VPN
connection is established. Select or create a Group Policy object.

Group Policy:* DfitGrpPolicy v | +

Edit Group Policy

- Klik op Edit Group Policy en selecteer op het tabblad AnyConnect de optie client Profileklikt u
vervolgens op Save:



Edit Group Policy (7]

Name:*
DfitGrpPolicy

Description:

General AnyConnect Advanced

Profile

AnyConnect profiles contains settings for the VPN client functionality and
Management Profile = optional features. Firewall Threat Defense deploys the profiles during

AnyConnect client connection.
Client Modules

SSL Settings Client Profile:
Anyconnect_profile A | +

Connection Settings

Custom Attributes Standalone profile editor can be used to create a new or modify existing
AnyConnect profile. You can download the profile editor from Cisco Software
Download Center.

- Selecteer op de volgende pagina de optie AnyConnect-afbeeldingen en klik op Next.
AnyConnect Client Image

The VPN gateway can automatically download the latest AnyConnect package to the client device when the VPN
connection is initiated. Minimize connection setup time by choosing the appropriate OS for the selected package.

Download AnyConnect Client packages from Cisco Software Download Center.

Show Re-order buttons 4

AnyConnect File Object Name AnyConnect Client Package Name Operating System

Anyconnectmac4.10 anyconnect-macos-4.10.06079-webdeploy... Mac OS v ‘

- Selecteer in het volgende scherm de optie Network Interface and Device Certificates:



Network Interface for Incoming VPN Access

Select or create an Interface Group or a Security Zone that contains the network interfaces users
will access for VPN connections.

Interface group/Security Zone:* | Outsied v | +

Enable DTLS on member interfaces

A All the devices must have interfaces as part of the Interface Group/Security Zone selected.

Device Certificates

Device certificate (also called Identity certificate) identifies the VPN gateway to the remote access
clients. Select a certificate which is used to authenticate the VPN gateway.

Certificate Enrollment:* vpntestbed.cisco.com v | +

Access Control for VPN Traffic

All decrypted traffic in the VPN tunnel is subjected to the Access Control Policy by default. Select
this option to bypass decrypted traffic from the Access Control Policy.

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)
This option bypasses the Access Control Policy inspection, but VPN filter ACL and
authorization ACL downloaded from AAA server are still applied to VPN traffic.

- Als alles goed is ingesteld, kunt u op Finish en vervolgens Deploy:



o 59 9 LI
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Remote Outside VPN

AnyConnect
User Client

Remote Access VPN Policy Configuration

Firepower Management Center will configure an RA VPN Policy with the following settings

Name: Anyconnect_RA

Device Targets: FTD

Connection Profile: Anyconnect_RA
Connection Alias: Anyconnect_RA
AAA:

Authentication Method:  AAA Only
Authentication Server: RadiusServer (RADIUS)

Authorization Server: RadiusServer (RADIUS)
Accounting Server; =
Address Assignment:
Address from AAA: -
DHCP Servers: -

Address Pools (IPv4): vpn_pool
Address Pools (IPv6): -

Group Policy: DMGrpPolicy
AnyConnect Images: Anyconnectmac4.10
Interface Objects: Qutsied
Device Certificates: vpntestbed.cisco.com

Device Identity Certificate Enrollment

Certificate enrollment object 'vpntestbed.cisco.com’ is not installed on one or more
targeted devices. Certificate installation will be initiated on the targeted devices on
finishing the wizard. Go to the Certificates page to check the status of the installation.

Device

5

ABA

Additional Configuration Requirements

After the wizard completes, the following
configuration needs to be completed for VPN to
work on all device targets.

© Access Control Policy Update

An Access Control rule must be defined to allow
VPN traffic on all targeted devices.

© NAT Exemption

If MAT is enabled on the targeted devices, you
must define a NAT Policy to exempt VPN traffic.

' DNS Configuration

To resolve hostname specified in AAA Servers
or CA Servers, configure DNS using FlexConfig
Policy on the targeted devices.

' Port Configuration

SSL will be enabled on port 443.

IPsec-IKEv2 uses port 500 and Client Services
will be enabled on port 443 for Anyconnect
image download.NAT-Traversal will be enabled
by default and will use port 4500.

Please ensure that these ports are not used in
NAT Policy or other services before deploying
the configuration.

A Network Interface Configuration

Make sure to add interface from targeted
devices to SecurityZone object 'Outsied’

- Hierdoor wordt de gehele configuratie gekopieerd, samen met certificaten en AnyConnect-

pakketten naar FTD-applicatie.

Connection

Om verbinding te maken met FTD moet u een browser, type DNS naam of IP-adres dat naar de
buiteninterface wijst openen. U logt vervolgens in met referenties die zijn opgeslagen in een
RADIUS-server en voert de instructies uit op het scherm. Nadat AnyConnect is geinstalleerd,
moet u hetzelfde adres in het AnyConnect-venster plaatsen en op Connect.

Beperkingen

Momenteel niet ondersteund op FTD, maar beschikbaar op ASA:

- De interfacekeuze in RADIUS-server wordt niet ondersteund op Firepower Threat
Defence6.2.3 of eerdere versies. De interfaceoptie wordt genegeerd tijdens plaatsing.

- Voor een dynamische RADIUS-server met autorisatie is Firepower Threat Defense6.3 of
hoger vereist om de dynamische autorisatie te kunnen gebruiken.

- FTDposture VPN ondersteunt groepsbeleidswijzigingen niet via dynamische autorisatie of



RADIUS-wijziging van autorisatie (CoA).

- AnyConnect-aanpassing (verbetering: Cisco-bug-id CSCvqg87631)

- AnyConnect-scripts

- AnyConnect-lokalisatie

- WSA-integratie

- Gelijktijdige IKEv2 dynamische cryptografische kaart voor RNA en L2L VPN (verbetering:
Cisco bug-id CSCvr52047)

- AnyConnect-modules (NAM, Hostscan, AMP Enabler, SBL, Umbrella, Web Security
enzovoort) - DART is standaard geinstalleerd (verbeteringen voor AMP Enabler en Umbrella:
Cisco bug-id CSCvs03562 en Cisco bug-id CSCvs06642).

- TACACS, Kerberos (KCD-verificatie en RSA/SDI)

- Browser Proxy

Beveiligingsoverwegingen

Standaard wordt de sysopt connection permit-vpnoptie is uitgeschakeld. Dit betekent dat u het verkeer
moet toestaan dat afkomstig is van de pool van adressen op buiteninterface via Access Control
Policy. Hoewel de voorfilter- of toegangscontroleregel wordt toegevoegd om alleen VPN-verkeer
toe te staan, wordt deze bij vergissing toegestaan als er clear-text verkeer gebeurt om aan de
regelcriteria te voldoen.

Dit probleem wordt op twee manieren benaderd. Ten eerste, TAC aanbevolen optie, is anti-
Spoofing inschakelen (op ASA was het bekend als Unicast Reverse Path Forwarding - uRPF) voor
buiteninterface, en ten tweede, moet inschakelen sysopt connection permit-vpn om de inspectie van de
snort volledig te omzeilen. De eerste optie staat een normale inspectie van het verkeer toe dat
naar en van VPN-gebruikers gaat.

a) URPF inschakelen

- Maak een nulroute voor het netwerk dat wordt gebruikt voor gebruikers van externe toegang,
zoals gedefinieerd in sectie C. Ga naar Devices > Device Management > Edit > Routing > Static Route €N
selecteer Add route


https://cdetsng.cisco.com/summary/#/defect/CSCvq87631
https://cdetsng.cisco.com/summary/#/defect/CSCvr52047
https://cdetsng.cisco.com/summary/#/defect/CSCvs03562
https://cdetsng.cisco.com/summary/#/defect/CSCvs06642

Add Static Route Configuration 7

Type: @ IPvd () IPV6
Interface*
\ Nullo v \

(Interface starting with this icon [ signifies it is available for route leak)

Available Network . Selected Network

Q, Search ‘ Add ‘ objvpnusers ™
any-ipvd
FMC
GW

IPvd-Benchmark-Tests
IPvd-Link-Local
IPvd-Multicast

Gateway*

Metric:
1

(1 -254)

Tunneled: [ | (Used only for default Route)

Route Tracking:

- Schakel vervolgens uRPF in op de interface waar de VPN-verbindingen eindigen. Om dit te
vinden, navigeer naar Devices > Device Management > Edit > Interfaces > Edit > Advanced > Security
Configuration > Enable Anti Spoofing.



Edit Physical Interface L]

General IPwd IPv6 Path Monitoring Hardware Configuration Manager Access Advanced
I

Information ARP Security Configuration

Enable Anti Spoofing:
Allow Full Fragment Reassembly:

Override Default Fragment Setting:

‘ Cancel |m

Wanneer een gebruiker is verbonden, wordt de 32-bits route voor die gebruiker in de
routeringstabel geinstalleerd. Wis het tekstverkeer dat afkomstig is van de andere, ongebruikte IP-
adressen uit de pool wordt door uRFP verwijderd. Om een beschrijving te zien van Anti-
spoofingRaadpleeg Beveiligingsconfiguratieparameters instellen bij Firepower Threat Defence.

b) Inschakelen Oysopt connection permit-vpn Optioneel

- Als u versie 6.2.3 of hoger hebt, is er een optie om dit te doen met de wizard of onder Devices >
VPN > Remote Access > VPN Profile > Access Interfaces.

Access Control for VPN Traffic

Bypass Access Control policy for decrypted traffic (sysopt permit—upn}

e

LA

-'ﬁ

~ I

f_,

pted traffic is subjected to Access Control Policy by default. This option

ALFLALF
B

L
¥
bypasses the inspection, but VPN Filter ACL and authorization ACL downloaded from

ALl server are still -\.-Ir_-'l-\.-l""l_ll to VPN trafiic.

- Voor versies voor 6.2.3, ga naar Objects > Object Management > FlexConfig > Text Object > Add Text Object.

- Maak een tekstobject variabele, bijvoorbeeld: vpnSysVar een enkele ingang met waarde
sysopt.

- Ga naar veld Objects> Object Management > FlexConfig > FlexConfig Object > Add FlexConfig Object.
- Maak de Flexconfig object met CLI connection permit-vpn.

- Plaats de variabele van het tekstobject in het veld Flexconfig object op de CLI met $vpnSysvar
connection permit-vpn. Klik Save:


/content/en/us/td/docs/security/firepower/622/configuration/guide/fpmc-config-guide-v622/interfaces_for_firepower_threat_defense.html?bookSearch=true#task_34BB9AC8E91946AB847C65FB79D67A5F

Insert Text Object Variable

Variable Name: | wpnSysvas
Description: [

Available Objects & Selected Object

[ 4, Search [T vpnSysvar

S ———

[0 repMssBytes
[T tepMssMinimum
[T threat_cetection_statistics

[T vadan_wve_only

[T vdtan_Port_and_Nve
[T wtan_wni

[T weepPassword

- Pas de Flexconfigobject als Append en selecteer implementatie om Everytime:

Edit FlexConfig Object ?

Name: | connection_permit-vpn

Description:

Queert s | B | Deplorment: ype:

...................................

Variables E]
vpnSysvar SINGLE sysopt FREEFORM:vpn.. false

[ Save J [ Cancel J

- Ga naar veldpevices > FlexConfig €n het huidige beleid te bewerken of een nieuw beleid te
maken met New Policy knop.

- Voeg alleen de gemaakte toe Flexconfigklikt u op save.
- Stel de configuratie aan voorziening opsysopt connection permit-vpnopdracht op het apparaat.

Hierna kunt u echter geen toegangscontrolebeleid gebruiken om verkeer te inspecteren dat van de
gebruikers afkomstig is. U kunt nog steeds VPN-filter of downloadbare ACL gebruiken om
gebruikersverkeer te filteren.



Als u gedropte pakketten met snort van VPN-gebruikers ziet, neemt u contact op met TAC en
verwijst u naar Cisco bug-id CSCvg91399.

Gerelateerde informatie

- Cisco technische ondersteuning en downloads



https://cdetsng.cisco.com/summary/#/defect/CSCvg91399
https://www.cisco.com/c/nl_nl/support/index.html?referring_site=bodynav

Over deze vertaling

Cisco heeft dit document vertaald via een combinatie van machine- en menselijke
technologie om onze gebruikers wereldwijd ondersteuningscontent te bieden in hun eigen
taal. Houd er rekening mee dat zelfs de beste machinevertaling niet net zo nauwkeurig is als
die van een professionele vertaler. Cisco Systems, Inc. is niet aansprakelijk voor de
nauwkeurigheid van deze vertalingen en raadt aan altijd het oorspronkelijke Engelstalige
document (link) te raadplegen.



