소개
이 문서에서는 Cisco 라우터 및 스위치에서 로컬 Windows/Linux/macOS PC로 파일을 안전하게 복사하는 방법에 대해 설명합니다.
사전 요구 사항
요구 사항
권한 레벨 15 액세스 권한이 있는 디바이스에 대한 SSH(Secure Shell) 도달 가능성에 대해 알고 있는 것이 좋습니다.
사용되는 구성 요소
이 문서의 정보는 다음 소프트웨어 및 하드웨어 버전을 기반으로 합니다.
- Cisco C9300-24P 스위치(Cisco IOS® 17.3.5 포함)
- Windows 10 OS
- RedHat Linux OS
이 문서의 정보는 특정 랩 환경의 디바이스를 토대로 작성되었습니다. 이 문서에 사용된 모든 디바이스는 초기화된(기본) 컨피그레이션으로 시작되었습니다. 현재 네트워크가 작동 중인 경우 모든 명령의 잠재적인 영향을 미리 숙지하시기 바랍니다.
배경 정보
이 문서에서는 TFTP(Trivial File Transfer Protocol), FTP(File Transfer Protocol), SFTP(Secure File Transfer Protocol) 또는 SCP(Secure Copy Protocol)와 같은 외부 서버 또는 소프트웨어를 사용할 필요 없이 Cisco 라우터/스위치에서 로컬 Windows/Linux/macOS PC로 파일을 안전하게 복사하는 방법에 대해 설명합니다.
문제
보안 환경에서는 TFTP/FTP/SFTP/SCP 서버에 접속하여 pcap, 충돌 파일, Cisco IOS 이미지 등의 파일을 라우터와 스위치에서 외부 소스로 복사하는 것이 어려울 수 있습니다. 방화벽이 소스 디바이스와 대상 디바이스 간에 앞에서 언급한 프로토콜에서 사용하는 포트를 차단할 가능성이 있습니다.
솔루션
Cisco 디바이스에서 SCP를 활성화하면 서버나 애플리케이션 없이 디바이스의 파일을 로컬 PC에 복사할 수 있습니다.
다음은 디바이스에 필요한 최소 컨피그레이션입니다.
hostname Switch
!
interface GigabitEthernet0/0
ip address 10.197.249.101 255.255.255.0
no shut
!
ip route 0.0.0.0 0.0.0.0 10.197.249.1
!
aaa new-model
!
aaa authentication login default local
aaa authorization exec default local
!
ip domain name cisco.com
!
!--- key used in this example is 1024
!
crypto key generate rsa
!
username cisco privilege 15 secret 5 <redacted>
!
line vty 0 x
transport input ssh
login local
!
ip scp server enable
!--- you can disable the above command after copy is completed
!
end
!--- optional
!
ip ssh time-out 60
ip ssh authentication-retries 5
ip ssh version 2
!
로컬 Windows/Mac/Linux에서 다음 명령을 사용하여 Cisco 라우터/스위치에서 파일을 복사합니다.
scp username@<ip_address_of_the_device>:flash:/filename
Windows 10:
C:\Users\mmehtabu.CISCO>cd /
C:\>cd ios
C:\ios>dir
Volume in drive C has no label.
Volume Serial Number is xxxx-yyyy
Directory of C:\ios
05-01-2023 09.32 AM <DIR> .
05-01-2023 09.32 AM <DIR> ..
0 File(s) 0 bytes
2 Dir(s) 163,191,525,376 bytes free
C:\ios> scp cisco@10.197.249.101:flash:/mycap.pcap .
Password:
mycap.pcap 100% 33MB 105.8KB/s 05:19
Connection to 10.197.249.101 closed by remote host.
C:\ios>dir
Volume in drive C has no label.
Volume Serial Number is xxxx-yyyy
Directory of C:\ios
05-01-2023 09.39 AM <DIR> .
05-01-2023 09.39 AM <DIR> ..
05-01-2023 09.40 AM 1,606,582 mycap.pcap
1 File(s) 1,606,582 bytes
2 Dir(s) 163,182,600,192 bytes free
Linux:
[root@root0 ~]# pwd
/root
[root@root ~]# ls -l
total 1
drwxr-xr-x. 2 root root 6 Apr 6 2022 Pictures
[root@root ~]# scp cisco@10.197.249.101:flash:/mycap.pcap .
Password:
flash:/mycap.pcap 100% 45MB 2.9MB/s 00:15
[root@cpnr000 ~]# ls -l
total 1580
-rw-r--r--. 1 root root 1606582 Jan 5 09:47 mycap.pcap
drwxr-xr-x. 2 root root 6 Apr 6 2022 Pictures
macOS에도 유사한 명령이 있습니다.
scp username@<ip_address_of_the_device>:flash:/filename
관련 정보