概要
このドキュメントでは、2 台の Nexus 7000 シリーズ スイッチのイーサネット ポート間のトラフィックをモニタする Nexus 7000 シリーズ スイッチでリモート スイッチド ポート アナライザ(RSPAN)セッションを設定する方法について説明します。
前提条件
要件
この設定を行う前に、次の要件が満たされていることを確認します。
使用するコンポーネント
このドキュメントの情報は、Nexus 7000 シリーズ NX-OS デバイスに基づくものです。
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、初期(デフォルト)設定の状態から起動しています。対象のネットワークが実稼働中である場合には、どのようなコマンドについても、その潜在的な影響について確実に理解しておく必要があります。
表記法
ドキュメント表記の詳細については、『シスコ テクニカル ティップスの表記法』を参照してください。
背景説明
ネットワーク アナライザがスイッチに接続する宛先ポートへのトラフィックのコピーを送信する、スイッチのポートまたは VLAN を通過するネットワーク トラフィックを分析するために、Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)を使用できます。
SPAN を拡張するために、RSPAN はネットワーク内の複数のスイッチのリモート モニタリングを有効にします。Nexus 7000 シリーズ スイッチは、RSPAN での動作が制限されています。RSPAN VLAN は、SPAN 宛先として使用できません。したがって、Nexus 7000 スイッチは、RSPAN を、トランジット VLAN またはソース VLAN として、RSPAN VLAN からデータを取得する目的でのみ使用できます。Nexus 7000 スイッチから RSPAN VLAN には何も配置できません。
設定
この設定例では、2 つの異なる Nexus 7000 シリーズ スイッチ上の送信元ポートと、もう 1 つの Nexus 7000 スイッチの宛先ポートを使用します。ここにネットワーク アナライザが接続されています。個別の Ethernet 1/1 リンクは、2 つのデバイス間で設定されています。1 つのリンクは SPAN 宛先として、もう 1 つのリンクは RSPAN VLAN へのアクセスとして設定されています。
注:このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool(登録ユーザ専用)を参照してください。一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことをご了承ください。
ネットワーク図
このドキュメントでは、次のネットワーク セットアップを使用します。
この例では、次のテーブルにリストされているポートを使用します。
デバイス |
送信元ポート |
宛先ポート |
Nexus 1 |
Ethernet 2/15 および 2/16 |
Ethernet 1/1 |
Nexus 2 |
Ethernet 1/1、2/26 から 2/28 |
Ethernet 2/37 から 2/40 |
Nexus 1 スイッチから、送信元からの SPAN トラフィックが宛先ポートに伝送され、RSPAN VLAN にコピーされます。トラフィックは、次にリンクを通して Ethernet 1/1 インターフェイスの Nexus 2 スイッチに転送されます。次に、SwitchProbe デバイスやその他のリモート モニタリング(RMON)プローブまたはセキュリティ デバイスなどのデバイスがパケットを受信して分析することができる、RSPAN VLAN トラフィックが宛先ポートに送信されます。
設定
このドキュメントでは、次の構成を使用します。
Nexus 1 |
Nexus1#configure terminal
!--- Configure the interface VLAN 15 as RSPAN VLAN.
Nexus1(config)#vlan 15
Nexus1(config-vlan)#remote-span
Nexus1(config-vlan)#exit
!--- Configure the switchport interface as a SPAN destination.
Nexus1(config)#interface ethernet 1/1
Nexus1(config-if)#switchport monitor
Nexus1(config-if)#no shutdown
Nexus1(config-if)#exit
!--- Configure the SPAN session.
Nexus1(config)#monitor session 1
!---Configure the source port.
Nexus1(config-monitor)#source interface ethernet 2/15-16
!--- Configure the destination port.
Nexus1(config-monitor)#destination interface ethernet 1/1
!--- Enable the SPAN session (by default the session is in shutdown state).
Nexus1(config-monitor)#no shut
Nexus1(config-monitor)#exit
|
Nexus 2 |
Nexus2#configure terminal
!--- Configuration of interface VLAN 15 as RSPAN VLAN.
Nexus2(config)#vlan 15
Nexus2(config-vlan)#remote-span
Nexus2(config-vlan)#exit
!--- Configure the switchport interface to access in RSPAN VLAN.
Nexus2(config)#interface ethernet 1/1
Nexus2(config-if)#switchport mode access
Nexus2(config-if)#switchport access vlan 15
Nexus2(config-if)#no shutdown
Nexus2(config-if)#exit
!--- Configure the switchport interfaces as a SPAN destination.
Nexus2(config)#interface ethernet 2/37-40
Nexus2(config-if)#switchport monitor
Nexus2(config-if)#exit
!--- Configure the SPAN session.
Nexus2(config)#monitor session 1
!--- Configure the source port.
Nexus2(config-monitor)#source interface ethernet 2/26-28
Nexus2(config-monitor)#source vlan 15
!--- Configure the destination port.
Nexus2(config-monitor)#destination interface ethernet 2/37-40
!--- Enable the SPAN session (by default the session is in shutdown state).
Nexus2(config-monitor)#no shut
Nexus2(config-monitor)#exit
|
確認
ここでは、設定が正常に機能しているかどうかを確認します。
アウトプット インタープリタ ツール(登録ユーザ専用)(OIT)は、特定の show コマンドをサポートします。OIT を使用して、show コマンドの出力の分析を表示します。
次に、SPAN および RSPAN の確認コマンドをいくつか示します。
Nexus 1:
-
RSPAN のセッションの状態を表示するには、show monitor コマンドを使用します。
Nexus1# show monitor
Session State Reason Description
------- ----------- ---------------------- --------------------------------
1 up The session is up
-
ERSPAN セッションの設定を表示するには、show monitor session [session session_number] コマンドを使用します。
Nexus1# show monitor session 1
session 1
---------------
type : local
state : up
source intf :
rx : Eth1/15 Eth1/16
tx : Eth1/15 Eth1/16
both : Eth1/15 Eth1/16
source VLANs :
rx :
tx :
both :
filter VLANs : filter not specified
destination ports : Eth1/1
Legend: f = forwarding enabled, l = learning enabled
-
デバイスのすべての ERSPAN セッションの設定を表示するには、show monitor session all コマンドを使用します。
Nexus 2:
関連情報