はじめに
このドキュメントでは、Cisco Secure Email Threat Defenseの修復エラーをトラブルシューティングする方法について説明します。
前提条件
要件
次の項目に関する知識があることが推奨されます。
- CiscoセキュアEメール脅威対策
- Microsoft O365スイート(Exchange Online、Entra、またはAzure AD)
使用するコンポーネント
このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づいています。
- CiscoセキュアEメール脅威対策
- Microsoft Exchange Online
- Microsoft Entra ID (以前のAzure AD)
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。本稼働中のネットワークでは、各コマンドによって起こる可能性がある影響を十分確認してください。
背景説明
Email Threat Defenseは、Microsoft Graph APIを使用してMicrosoft 365と通信し、ごみ箱への移動、ジャンクへの移動、検疫への移動などの非常に迅速な検出と修復を可能にします。
問題
場合によっては、Secure Email Threat Defense(SEAT)の修復で、さまざまな理由でエンドユーザのメールボックスから電子メールを移動または隔離できないことがあります。
解決方法
説明したさまざまな状況で修復が失敗する。
シナリオ1:リソースが見つからない
Eメールによる脅威対策の修復が「Resource is Not Found」で失敗する
エラーリソースが見つかりません
原因
1. メールボックス所有者によって、電子メールが削除されるか、別のフォルダに移動されます。
2. Microsoft O365管理センターでアカウントが作成されましたが、ライセンスが割り当てられておらず、メールボックスも設定されていません。
Microsoft O365管理センターでユーザーのサブスクリプション状態を確認します。正しいExchange Onlineライセンスを割り当てて、影響を受けるユーザのメールボックスを自動作成します。
シナリオ2:修復に失敗しました – 原因不明
Eメールによる脅威対策の修復が「Remediation Failed - Unknown Reason」で失敗する。
エラー修復に失敗しました – 原因不明
原因
登録されているセキュリティで保護された電子メール脅威に対する防御アプリケーションのMicrosoft Entra IDに対する権限が正しくないか、または設定されていない。
1. Microsoft 365 Admin Centerに少なくとも1人のクラウドアプリケーション管理者としてログインします。左側のメニューでAdmin Centersを展開し、Identityをクリックします。
2. Identity > Applications > Enterprise Applicationsの順に移動し、登録済みのSecure Email Threat Defense Applicationをクリックします。Permissionsに移動します。
3. アプリケーションにタイプApplicationの正しいMicrosoft Graph API権限があることを確認します。
- メール。読み取り/書き込み
- 組織。読み取り。すべて
不足している権限がある場合は、Grant Admin Consent for <Tenant-ID>をクリックします。 Cloud Adminアカウントでログインし、Acceptをクリックします。
シナリオ3:要求されたユーザが無効である
Eメールによる脅威対策の修復が「The Requested User is Invalid」で失敗する。
エラー要求されたユーザーが無効です
原因
1. メールボックスまたはユーザーアカウントが無効であるか、Microsoft O365組織ディレクトリに存在しません。
2. セキュアな電子メール脅威に対する防御は、複数のテナントまたはドメインと統合されます。ただし、Entra ID (Azure AD)に登録されているアプリケーションは、単一のテナントにアクセスできます。
ユーザアカウントまたはメールボックスが有効で、Microsoft O365に存在することを確認します。
マルチテナント環境では、登録されたSecure Email Threat Defenseアプリケーションに、任意の組織ディレクトリのアカウントにアクセスする権限があることを確認します。
シナリオ4:メールボックスが非アクティブ、ソフト削除、またはオンプレミスでホストされている
Eメールによる脅威に対する防御の修復が「メールボックスが非アクティブ、ソフト削除、またはホスト型オンプレミスである」で失敗する。
エラーメールボックスが非アクティブまたはソフト削除されている
原因
1. Microsoft Entra Identity (以前のAzure AD)でアカウントが設定されていますが、割り当てられた有効なM365またはExchange Onlineライセンスがありません。
2. Microsoft O365とオンプレミスExchangeを使用したハイブリッドセットアップで、Microsoftオンプレミスサーバー上にユーザーアカウントのみが存在する。
Microsoft O365管理センターでユーザーのサブスクリプション状態を確認します。正しいExchange Onlineライセンスを割り当てて、影響を受けるユーザのメールボックスを自動作成します。
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