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Add Cert Enroliment (7]

Name*
vpntestbbed.cisco.com
Description
|
CA Information Certificate Parameters Key Revocation

Enrollment Type: | Manual v
[ ] CA Only
Check this option if you do not require an identity certificate fo be created
from this CA
CA Certificate: Ep':“_ Iangreno .. ST2xar
YfPCilB7g

BMAV7Gzdc4VspS6ljirAhbiiaw
dBiQIQmsBeFz9JkF4..b3I8Bo
GN+gMa56Y
lt8unaZgY4l20//on88r5IWJIm

Validation Usage: IPsec Client SSL Client [ | SSL Server
| | Skip Check for CA flag in basic constraints of the CA Certificate

|| Allow Overrides

Cancel Save

- iR Enroliment Type [Certificate Authority (CA) certificate ( CSROEBRIZFERE Nh3iHEE ) 1%
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Add Cert Enroliment Q

Name*
vpntesthbed.cisco.com
Description
CA Information Certificate Parameters Key Revocation

Include FQDN: Use Device Hostname as FODN

Include Device's IP Address: 10.88.243.123

Common Mame (CN): vpntestbed.cisco.com

Organization Unit (OU): TAC

Organization (0): | Mexico

Locality (L): | MX

State (ST): CDMX

Country Code (C): | MX

Email (E): I tac@cisco.com

Include Device's Serial Number | |

|| Allow Overrides

Cancel Save

-3FEDRT T, keyType, BEIEH A XEERLE T, RSADFE, 2048EY R ETT,
- [R7FE(Save)|Z 71U Y U LT, Devices > Certificates > Add > New Certificate.
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Add New Certificate (7]

Add a new certificate to the device using cert enrollment object which is used to
generate CA and identify certificate.

Device®:
FTD v

Cert Enrollment®:

l vpntestbed.cisco.com| v ‘ +

Cert Enrollment Details:

MName: vpntestbed.cisco.com

BT, RSARNRA Y REDRICHD D FAOAVEIUYIL, vesEDH. CSRECAK
OdE—ULTEERELET, HRAEICE. BEEOHTTPSY—NEBUBMNBETT,
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b) RADIUSY —/XDEE

. ;J’Q = Objects > Object Management > RADIUS Server Group > Add RADIUS Server Group.

.BEZEADL, IPPRLAEEEWBZZEBML T, save:



Edit RADIUS Server

IP Address/Hostname:*

192.168.20.7 |
Configure DNS at Threat Defense Platform Settings to resolve hostname
Authentication Port:* (1-65535)

1812
Key:*

Accounting Port: (1-65535)
1813

Timeout: (1-300) Seconds
10

Connect using:
(® Routing () Specific Interface @

Default: Management/Diagnostic i

Redirect ACL:

- T0E, Y—NHAVAMNCRRENET,
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- RIS Objects > Object Management > Address Pools > Add IPv4 Pools.

- BHEHEHFAEANLET, NATVREBEHY EHBA,
Name*

I vpn_pool ‘

IPv4 Address Range*
\ 10.72.1.1-10.72.1.150 \

Mask
‘ Specify a netmask in X.X.X.X format ‘

Description

Allow Overrides

. Configure device overrides in the address pool object to
avoid IP address conflicts in case of object is shared across
multiple devices

»  Override (0)

d) XMLZO7 7 1 L OAER

- AN Y A N SProfile Editorg X > O—RLUTHEEE T,
- JRAZ server List > Add...
- [Display Name] &[FQDN]Z AL E T, [Server ListllC XODIT NUAFHVYET,

[ AnyConnect Profile Editor - VPN — O *
File Help
4 -
L VPN | Server List

{§ Preferences (Part 1) . .
lllll % preferences (part 2 Profile: C:AUsers\calo\Documents\Anyconnect_profile.xml

----- % Backup Servers
----- # Certificate Pinni
= C:;tiﬁi:te I't"::gigng Hostname Host Address User Group Backup Server List SCEP Mobile Settings Certificate Pins
_____ Z Certificate Enrollment VPM(S5L) vpntestbed.dsco.... -- Inherited --
[} Mobile Policy VPN(IPSEC) vpntestbed. dsco.... - Inherited -

----- Server List

Mote: it is highly recommended that at least one server be defined in a profile. Add... ' Delete

. 21)Y %Y ok& File>Saveas...



e) AnyConnectf X—OF v 7’ O0—R

DAY A MDA SpkgA X—2 72XV O0—RULET,
. ;)'t (el Objects > Object Management > VPN > AnyConnect File > Add AnyConnect File.

- BHZEADL, TAAIODSPKGT7 7AINZBIRL, save:

Edit AnyConnect File

Mame:*

I Wnyconnectmac4.10 |

File Name:*

| anyconnect-macos-4.10.06079-webdef | | Browse..
File Type:*

| AnyConnect Client Image v |
Description:

| Cancel

CBEAOEHCEIVTINYr—YEEMLET,
2VE—RNFPIEAVA4Y—FK

- JX\Z Devices > VPN > Remote Access > Add a new configuration.

-ZA7T7ANICERMENT. FIDFNA RAZERLET,



Targeted Devices and Protocols

This wizard will guide you through the required minimal steps to configure the Remote
Access VPN policy with a new user-defined connection profile.

Mame:*

| Anyconnect_RA |

Description:

VPN Protocols:

SSL
IPsec-IKEv2

Targeted Devices:

Available Devices Selected Devices

| Q_ Search | FTD

FTD

. [Connection Profile] A7 Y 7T, RO XS IZ AL F T Connection Profile Name Z &R L .
Authentication Server & Address Pools SA BT IC/ERX L =€ D :



Connection Profile:

Connection Profiles specify the tunnel group policies for a VPN connection. These policies pertain to creating the
tunnel itself, how AAA is accomplished and how addresses are assigned. They also include user attributes, which
are defined in group policies.

Connection Profile Name:* | Anyconnect_RA

I @ This name is configured as a connection alias, it can be used to connect to the VPN gateway

Authentication, Authorization & Accounting (AAA):

Specify the method of authentication (AAA, certificates or both), and the AAA servers that will be used for VPN
connections.

Authentication Method: [ AAA Only v l

RadiusServer v l -+
(LOCAL or Realm or RADIUS)
[ Fallback to LOCAL Authentication

Authentication Server:*

Authorization Server: | Use same authentication server | +
(Realm or RADIUS)

Accounting Server: | v | -
(RADIUS)

Client Address Assignment:

Client IP address can be assigned from AAA server, DHCP server and IP address pools. When multiple options are
selected, IP address assignment is tried in the order of AAA server, DHCP server and IP address pool.

] Use AAA Server (Realm or RADIUS only) @
[ ] Use DHCP Servers
Use IP Address Pools

IPvd Address Pools: | vpn_pool

N

IPv6 Address Pools: I

Group Policy:

A group policy is a collection of user-oriented session attributes which are assigned to client when a VPN
connection is established. Select or create a Group Policy object.

Group Policy:* DfitGrpPolicy v | +

Edit Group Policy

- 1) Y % Edit Group Policy [AnyConnect]®X 7 T, ClientProfile® 7 1) Y Z L, save:



Edit Group Policy (7]

Name:*
DfitGrpPolicy

Description:

General AnyConnect Advanced

Profile

AnyConnect profiles contains settings for the VPN client functionality and
Management Profile = optional features. Firewall Threat Defense deploys the profiles during
AnyConnect client connection.

Client Modules

SSL Settings Client Profile:

Connection Settings Anyconnect_profile v | +

Custom Attributes Standalone profile editor can be used to create a new or modify existing

AnyConnect profile. You can download the profile editor from Cisco Software
Download Center.

- ROAR—Z T, [AnyConnect images]ZiZIR L. Next.
AnyConnect Client Image

The VPN gateway can automatically download the latest AnyConnect package to the client device when the VPN
connection is initiated. Minimize connection setup time by choosing the appropriate OS for the selected package.

Download AnyConnect Client packages from Cisco Software Download Center.

Show Re-order buttons 4

AnyConnect File Object Name AnyConnect Client Package Name Operating System

Anyconnectmac4.10 anyconnect-macos-4.10.06079-webdeploy... Mac OS v ‘

. JXDIEME T, Network Interface and Device Certificates:



Network Interface for Incoming VPN Access

Select or create an Interface Group or a Security Zone that contains the network interfaces users
will access for VPN connections.

Interface group/Security Zone:* | Outsied v | +

Enable DTLS on member interfaces

A All the devices must have interfaces as part of the Interface Group/Security Zone selected.

Device Certificates

Device certificate (also called Identity certificate) identifies the VPN gateway to the remote access
clients. Select a certificate which is used to authenticate the VPN gateway.

Certificate Enrollment:* vpntestbed.cisco.com v | +

Access Control for VPN Traffic

All decrypted traffic in the VPN tunnel is subjected to the Access Control Policy by default. Select
this option to bypass decrypted traffic from the Access Control Policy.

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)
This option bypasses the Access Control Policy inspection, but VPN filter ACL and
authorization ACL downloaded from AAA server are still applied to VPN traffic.

CIRTHAELLKBEE NS, Finish T D Deploy:
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Remete Access VN Policy Configurstion Additional Configuration Requirements

Firepower Management Center will configure an RA VPN Policy with the following settings After the wizard completes, the following
configuration needs to be completed for VPN to

work on all device targets.

Name: Anyconnect_RA

Device Targets: FTD

Connection Profile:
Connection Alias:
AAA:

Authentication Method:

Authentication Server:
Authorization Server:
Accounting Server;
Address Assignment:
Address from AAA:
DHCP Servers:
Address Pools (IPvd):
Address Pools (IPv6):
Group Policy:
AnyConnect Images:
Interface Objects:

Device Certificates:

Anyconnect_RA

Anyconnect_RA

AAA Only
RadiusServer (RADIUS)
RadiusServer (RADIUS)

vpn_pool
DMGrpPolicy
Anyconnectmac4.10
Qutsied

vpntestbed.cisco.com

© Access Control Policy Update

An Access Control rule must be defined to allow
VPN traffic on all targeted devices.

© NAT Exemption

If MAT is enabled on the targeted devices, you
must define a NAT Policy to exempt VPN traffic.

@ DNS Configuration

To resolve hostname specified in AAA Servers
or CA Servers, configure DNS using FlexConfig
Policy on the targeted devices.

@ Port Configuration

SSL will be enabled on port 443.

IPsec-IKEv2 uses port 500 and Client Services
will be enabled on port 443 for Anyconnect
image download.NAT-Traversal will be enabled

by default and will use port 4500.
Please ensure that these ports are not used in
NAT Policy or other services before deploying
the configuration.
Device Identity Certificate Enrollment

A Network Interface Configuration
Certificate enrollment object 'vpntestbed.cisco.com’ is not installed on one or more
targeted devices. Certificate installation will be initiated on the targeted devices on
finishing the wizard. Go to the Certificates page to check the status of the installation.

Make sure to add interface from targeted
devices to SecurityZone object 'Outsied’
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ZHR—RNLTLVERA,

- AnyConnect® 1 AR N 4 X(#EEHL5E : Cisco Bug ID CSCvg87631)

- AnyConnectA 7 1J 7'k
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BEBEFLER : Cisco Bug ID CSCvs03562% & T Cisco Bug ID CSCvs06642).

. TACACS, Kerberos ( KCDFZEES & U'RSA SDI )
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RIV—BEBNLTABA UV EZ—T IAADT RLAT=IDSEFEENBDI RN T4V UV ZEFAT
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COBBIZRE22OT77O—FHFHYNET, 128, TACKHERTZ AT 32T, A1 2
—TJIARAIRUTTUOFRT =T 12T 2BMICT S & TF(ASATIEUnicast Reverse Path
Forwarding(uURPF)EEIENTWVWERL ) 208, BRIZT B Z & T sysopt connection permit-

von SNOMREZZEICNA/NALET, BRUOFA T3 Tk, VPNI—HEOBTRUEY X
NBDRTTAVIEBEDHAETRETEET,

a) URPFD AL

9232 CTERLE, UE—RMNTP7OVEAI—HVICFERATRIZIRYRNT—TDORI)IIL—K%Z
1/E}ﬁl/§3-o Devices > Device Management > Edit > Routing > Static Route Eigﬁb\ Add route
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Add Static Route Configuration 7

Type: @ IPvd () IPV6
Interface*
\ Nullo v \

(Interface starting with this icon [ signifies it is available for route leak)

Available Network . Selected Network

Q, Search ‘ Add ‘ objvpnusers ™
any-ipvd
FMC
GW

IPvd-Benchmark-Tests
IPvd-Link-Local

IPvd-Multicast

Gateway*

Metric:
1

(1 -254)

Tunneled: [ | (Used only for default Route)

Route Tracking:

CRIC, VPNERARIRTEDA 2 RXR—TIAATURPFZAMICLET, ChZzRO20F3ICE.

Devices > Device Management > Edit > Interfaces > Edit > Advanced > Security Configuration > Enable Anti

Spoofing.



Edit Physical Interface

General IPwd IPv6 Path Monitoring Hardware Configuration

Information ARP Security Configuration

Enable Anti Spoofing:
Allow Full Fragment Reassembly:

Override Default Fragment Setting:

Advanced

Manager Access

‘ Cancel |m

I—¥HERENDE, TOI—HDR2EY NIL—KFIL—F 12 TFF7—TINICA 2V AR=ILE
nNET, 7D SEEENEMOKRERIPT RLAASEFENETFANNT T4V I%D
)7 9$25E, URFPICEK P THREENET, siBAZEKRRT B IZIE Anti-spoofing TFirepower Threat
Defense TR EF IV T AHRENTAXA—ZDEEL 2SBL TS EEL,

b)E%b sysopt connection permit-vpn 7S 3>

=2 3623 BREFALTVIEAR, JIHF—RELROTTEIIZDATI 3N
5 U ﬁ 3' Devices > VPN > Remote Access > VPN Profile > Access Interfaces.

Access Control for VPN Traffic

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)

Decrypted traffic is subjected to Access Control Policy by default. This option

R aT e =T ] & et e .. I [ W]
oypasses e nspechion, oul VN

AAA server are still applied to VPN trafiic.

=i PO | R Y E—- L Tl RO [ [ I S
Filter ACL and authorization ACL downloaded from

623K VWEION—23 IOV TE, 25U TLKEE L, Objects > Object Management

> FlexConfig > Text Object > Add Text Object.

CTEFANAT DTN EERLUET, Bl : vpnSysVarfBZEFEDE—NDTI > MY sysopt.
/' Objects> Object Management > FlexConfig > FlexConfig Object > Add FlexConfig Object.
. Cisco Unified Communications Manager® Flexconfig CLIZER L =747 T2 N connection

permit-vpn.

THFANFT DT NEBE FlexConfig CLITA 7 T O N ZEEEL E T, $vpnSysvar connection

permit-vpn. 7 1J Y 9 save:
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/content/en/us/td/docs/security/firepower/622/configuration/guide/fpmc-config-guide-v622/interfaces_for_firepower_threat_defense.html?bookSearch=true#task_34BB9AC8E91946AB847C65FB79D67A5F

Insert Text Object Variable

Vanable Name: VDNSyEVar
Description: [

Available Objects & Selected Object

[ 4, Search [T vpnSysvar

ST ———

[0 repMssBytes
[T tepMssMinimum
[T threat_cetection_statistics

[T vadan_wve_only

[T vdtan_Port_and_Nve
[T vatan_wini

[T weepPassword

. Cisco Unified Communications Manager® Flexconfig~ & LU TEZEZIBX % Append B A & iEIR
LT Everytime:

Edit FlexConfig Object ? X
Name: | connection_permit-vpn
Description:

@ Insert - | | Deployment: Everytime 3| Type:
SvpnSysVar connection permit-ven
Variables E]
vpnSysvar SINGLE sysopt FREEFCRM:vpn.. false

[ Save J[ Cancel J

. ;)’u:Devices>FlexConfig EE.T:I_:G)I'KU:/—E%JEE?%’#\ %ﬁb\,\/‘ﬁ'ﬁ/—’é#ﬁibi?o New
Policy 22V OLT, JIV—ZRXRTLET,
- YERR L 7= Flexconfige 7 ') Y Z L, save.
. 7°|:| E§3:/7‘?%*§ﬁﬁﬁﬁﬁbi?sysopt connection permit-vpn:|7> RzF/INA Xf%ﬁ'
LET,
EEL, CO®, TOEAODAYNO-ILRIVS—2EALTIA—FHSEFBIRDNTF T4V D
EREITDERFTEEFEA, - YRS TA4VYIOOT1INZUTICE, BIEHEVPNT 1)L



AFREFAVO—RITEACLEERATEERT,

VPNI—HASOSnontT/NTY RO ROYTZ7HFRShBFEE. TACIZEWVWEE TCisco Bug ID
CSCvg91399& SR L TS & L\,

BOE1E ]

ATV ALY R—BPBLTF I O— R



https://cdetsng.cisco.com/summary/#/defect/CSCvg91399
https://www.cisco.com/c/ja_jp/support/index.html?referring_site=bodynav

BERICDW\T

VZAARIMRFOI—HFITEFNZFNDOEETHR—b VT VY ERHEITZ/HIC, #HEAIC
LBBREMBEDET. FARF XY MEBRLUTVET. L. BREEOKMERTH -
TH, EMARICLDFROLS BRIEERIIERINT BA. X3, ChSEIRROIEHE®ICD

WTERNEEZEVWEEA. BETHZHEEBIR (VIS5 T7 I EATEE) bHHhETESRTS
CETEHRULIEY,



