はじめに
このドキュメントでは、EIGRPとBGP間の相互再配布を設定する方法について説明します。
前提条件
要件
次の項目に関する知識があることが推奨されます。
使用するコンポーネント
このドキュメントの情報は、Cisco IOS®ソフトウェアリリース15.0(1)を搭載したCisco 7200シリーズルータに基づくものです。
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。本稼働中のネットワークでは、各コマンドによって起こる可能性がある影響を十分確認してください。
表記法
表記法の詳細については、『シスコ テクニカル ティップスの表記法』を参照してください。
設定
この例では、ルータ R1 および R2 は EIGRP を使用して相互に通信します。ルータ R2 および R3 は eBGP を使用します。eBGPルートをEIGRPに相互に再配布するために、EIGRPメトリックのredistribute bgpコマンドを使用します。同様に、EIGRPルートをBGPに再配布するために、redistribute eigrp AS number コマンドを使用します。
ネットワーク図
このドキュメントでは、次のネットワーク セットアップを使用します。
ネットワーク図
コンフィギュレーション
このドキュメントでは、次のコンフィギュレーションを使用します。
ルータ R1 |
!
hostname R1
!
ip cef
!
!
interface Loopback0
ip address 10.30.30.30 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.101 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
network 10.30.0.0
network 192.168.1.0
no auto-summary
!
end
|
ルータ R2 |
!
hostname R2
!
ip cef
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface Loopback1
ip address 10.20.20.20 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.100 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.16.100.50 255.255.255.0
serial restart-delay 0
clock rate 2000000
!
router eigrp 100
redistribute static
redistribute bgp 1000 metric 100 1 255 1 1500
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
router bgp 1000
no synchronization
bgp log-neighbor-changes
network 10.20.20.20 mask 255.255.255.255
redistribute connected
redistribute static
redistribute eigrp 100
neighbor 172.16.100.51 remote-as 2000
neighbor 172.16.100.51 next-hop-self
no auto-summary
!
end
|
ルータ R3 |
!
hostname R3
!
ip cef
!
interface Loopback0
ip address 10.22.22.22 255.255.255.255
!
interface Serial0/0
ip address 172.16.100.51 255.255.255.0
serial restart-delay 0
clock rate 2000000
!
router bgp 2000
no synchronization
bgp log-neighbor-changes
network 10.22.22.22 mask 255.255.255.255
network 172.16.100.0 mask 255.255.255.0
neighbor 172.16.100.50 remote-as 1000
neighbor 172.16.100.50 default-originate
default-information originate
!--- Default route is configured!
no auto-summary
!
end
|
確認
ここでは、設定が正常に機能しているかどうかを確認します。
CLIアナライザは、show コマンド出力の分析を表示するために使用します。
注:シスコの内部ツールおよび情報にアクセスできるのは、登録ユーザのみです。
show コマンド
EIGRPが再配布されたルートを受信していることを確認するには、show ip route eigrp コマンドを使用します。
show ip route eigrp |
ルータ R1 内 R1#show ip route eigrp
10.20.0.0/32 is subnetted, 1 subnets
D EX 10.20.20.20
[170/25625856] via 192.168.1.100, 01:00:33, FastEthernet0/0
10.22.0.0/32 is subnetted, 1 subnets
D EX 10.22.22.22
[170/25625856] via 192.168.1.100, 00:59:49, FastEthernet0/0
10.0.0.0/32 is subnetted, 1 subnets
D 10.10.10.10 [90/409600] via 192.168.1.100, 00:55:17, FastEthernet0/0
D*EX 0.0.0.0/0 [170/25625856] via 192.168.1.100, 00:46:24, FastEthernet0/0
!--- Shows the default route from router R3.
!--- EX indicates that the routes are EIGRP external routes.
|
EIGRPルートがBGPに正しく再配布されていることを確認するには、ルータR3でshow ip route bgpコマンドを使用します。
show ip route bgp |
ルータ R3 内 R3#show ip route bgp
show ip route bgp
10.20.0.0/32 is subnetted, 1 subnets
B 10.20.20.20 [20/0] via 172.16.100.50, 01:03:02
10.0.0.0/32 is subnetted, 1 subnets
B 10.10.10.10 [20/0] via 172.16.100.50, 01:03:02
B 192.168.1.0/24 [20/0] via 172.16.100.50, 01:03:02
10.30.0.0/32 is subnetted, 1 subnets
B 10.30.30.30 [20/409600] via 172.16.100.50, 00:59:06
!--- The output indicates that the EIGRP routes are !--- redistributed in BGP.
|
関連情報