Introduzione
In questo documento viene descritto come risolvere i problemi relativi a Call Studio 11.0 o Call Studio 11.5 quando non è possibile importare progetti da Call Studio 10.5 a Call Studio 11.0.
Prerequisiti
Requisiti
Cisco raccomanda la conoscenza dei seguenti argomenti:
- CVP Call Studio
- CVP Call Server
Le informazioni fornite in questo documento si basano sulle seguenti versioni software:
- CVP Server 11.5
- CVP Call Studio 11.5
Problema
Gli script di Call Studio sono stati sviluppati in Call Studio versione 10.5. Quando viene importato in CallStudio versione 11.0/11.5, per alcuni script l'importazione non è riuscita e ha mostrato un messaggio di errore.
Messaggio di errore
Questo messaggio di errore indica quando viene importato lo script di Call Studio "Importazione progetto Call Studio non riuscita: Il progetto contiene un elemento Start of Call con lo stesso nome di un altro elemento nel flusso principale. A partire da Call Studio 10.5(1), il nome dell'elemento Start of Call deve essere univoco. Rinominare utilizzando la versione precedente di Call Studio e riprovare".
Possibili cause
A partire da Call Studio 11.0, nessun elemento può avere lo stesso nome dell'elemento "start of call".
Questa è la causa principale del messaggio di errore che è possibile vedere per l'importazione delle app meno recenti, che consentivano lo stesso.
Soluzione
Azione consigliata
Passaggio 1. Importare il progetto con problemi in Call Studio 11.5 come progetto normale (non come progetto Call Studio). Importazione del progetto completata.
Passaggio 2. Cercare il nome dell'elemento di inizio chiamata dell'applicazione.
Passaggio 3. Se in una pagina dell'applicazione sono presenti più occorrenze di tale errore, questa è la causa principale dell'errore di importazione.
Passaggio 4. Nella pagina principale creare un nuovo elemento Immissione pagina insieme all'elemento di inizio chiamata.
Passaggio 5. Posizionare lo stato di uscita di questo nuovo elemento sullo stesso elemento a cui punta l'elemento iniziale della chiamata.
Passaggio 6. Posizionare le occorrenze dei connettori di immissione della pagina, aventi lo stesso nome dell'elemento iniziale della chiamata, in modo che puntino al nuovo elemento Immissione pagina creato nella pagina principale.
Passaggio 7. L'applicazione è ora compatibile con Call Studio 11.0 / 11.5, salvarla ed esportarla.
Passaggio 8. Eliminare il progetto importato e reimportarlo come progetto esistente di Call Studio.
Nota: questo difetto CSCvb95979 è stato aperto per il problema.