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Introducción

Este documento describe cómo actualizar una imagen de software en Cisco ASA 5500 Series
Adaptive Security Appliances usando el Cisco Adaptive Security Device Manager (ASDM).

El ASDM no funciona si actualiza (o instalar una versión anterior) el software del dispositivo de
seguridad a partir del 7.0 a 7.2 directamente o actualiza (o instala una versión anterior) del
software ASDM a partir del 5.0 a 5.2 directamente. Necesita hacerlo en orden incremental.

Ejemplo: Para realizar la actualización del software ASDM a partir del 5.0 a 5.2, primero actualice
a partir de 5.0 a 5.1 y luego actualice a partir de 5.1 a 5.2. De igual manera, para el dispositivo de
seguridad, primero actualice desde 7.0 a 7.1 y luego actualice desde l 7.1 a 7.2.

Nota: Si desea actualizar o actualizar de la versión 7.1.x a la 7.2(x) y viceversa, debe seguir los
pasos de este procedimiento, ya que las versiones anteriores del dispositivo de seguridad no
reconocen nuevas imágenes ASDM y las nuevas imágenes del dispositivo de seguridad no
reconocen las imágenes ASDM antiguas. Consulte la sección Actualización de una nueva versión
de software de Cisco PIX Security Appliance Release Notes, versión 7.2(2) para obtener más
información sobre los procedimientos de actualización.

Nota: No puede rebajar el ASA 5550 a una versión de software anterior a 7.1(2). De igual manera,
no puede instalar una versión de software de ASA 5505 anterior a 7.2. Consulte Compatibilidad
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de Hardware y Software Cisco ASA 5500 Series y PIX 500 Series Security Appliance para más
información.

Nota: En el modo Multicontext, no puede utilizar el comando copy tftp flash para actualizar o
degradar la imagen PIX/ASA en todos los contextos; se soporta solamente en el modo EXEC del
sistema.

Prerequisites

Requirements

No hay requisitos específicos para este documento.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y
hardware.

Cisco ASA 5500 7.0 y posterior●

Cisco ASDM 5.0 y posterior●

The information in this document was created from the devices in a specific lab environment. All of
the devices used in this document started with a cleared (default) configuration. If your network is
live, make sure that you understand the potential impact of any command.

Productos Relacionados

Esta configuración también se puede utilizar con la Cisco PIX 500 Series Security Appliance
Software Version 7.0 y posterior.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las
convenciones sobre documentos.

Descargar Software

Puede descargar la versión de lanzamiento necesaria de imágenes de software ASA e imágenes
de software ASDM mediante los siguientes enlaces:

Descarga de la versión del software Cisco ASA (sólo clientes registrados)●

Descarga de la versión del software Cisco ASDM (sólo clientes registrados)●

Nota: Necesita tener credenciales de usuario de Cisco válidas para descargar este software de
Cisco.com.

Actualización de una Imagen de Software con ASDM 5.x

Complete estos pasos para actualizar una imagen de software en el ASA 5500 con ASDM.
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Seleccione Tools > Upgrade Software... desde la ventana de inicio del
ASDM.

1.

Seleccione el tipo de imagen que desea cargar del menú
desplegable.

2.

Haga clic en Examinar archivos locales... o escriba la ruta en el campo Trayectoria de
archivo local para especificar la ubicación de la imagen de software en el PC.

3.

Haga clic en Examinar Flash....Una ventana de diálogo de la memoria flash aparece con el
nombre del archivo ingresado automáticamente. Si no aparece el nombre del archivo,
ingréselo manualmente en el campo de nombre del archivo. Haga clic en Aceptar cuando
haya

4.



terminado.

Una vez que se especifican los nombres del archivo local y elarchivo remoto, haga clic en
Cargar
Imagen.

5.



Una ventana de estado aparece mientras que el ASDM escribe la imagen en
Flash.

Una vez finalizada la tarea, aparece la ventana Información que indica una carga
satisfactoria.

Haga clic en Aceptar en la ventana Información y, a continuación, Cerrar en la ventana
Cargar imagen desde PC local.

6.

Elija Configuration > Properties > Device Administration > Boot Image/Configuration > Edit
para cambiar la ubicación de la imagen de
inicio.

7.



Haga clic en Buscar Flash para seleccionar o especificar un archivo de imagen ASA . Luego
haga clic en OK
(Aceptar).

Elija File > Save Running Configuration to Flash para almacenar la configuración en la
memoria
Flash.

8.



Elija Tools > System Reload de la ventana principal para recargar el
dispositivo.

9.

Una nueva ventana aparece que le solicita que verifique los detalles de la recarga.
Seleccione Guardar la configuración actual en el momento de la recarga y después elija la
fecha y hora de recarga.Ahora - Reinicia el dispositivo inmediatamente.Retraso por -
Especifica los minutos u horas que se necesitan para recargar el dispositivo.Programado

10.



para — Especifica la fecha y hora de la recarga del dispositivo.También puede especificar
si el dispositivo debe forzar una recarga de inmediato si falla la recarga programada. Error
al Comprobar la Recarga fuerza una recarga inmediata después y luego especifica un
tiempo de espera máximo. Ésta es la cantidad de tiempo que el dispositivo de seguridad
espera para notificar otros subsistemas antes de un shutdown o reboot. Después de este
tiempo, se produce un rápido (forzado) shutdown/reboot Haga clic en Programar
Recarga.

Una vez que la recarga está en curso, una ventana de Estado aparece que indica que se
está realizando una recarga. También tiene la opción de salir del ASDM .Nota: Vuelva a
iniciar el ASDM después de que el ASA se
recargue.

11.



Actualización de una Imagen de ASDM con ASDM 5.x

Complete estos pasos para actualizar una Imagen de ASDM en ASA 5500 con ASDM.

Elija Tools > Upgrade Software... desde la ventana de inicio del
ASDM.

1.



Seleccione el tipo de imagen que desea cargar del menú
desplegable.

2.

Haga clic en Examinar local... o escriba la ruta en el campo Trayectoria de archivo local para
especificar la ubicación de la imagen ASDM en su PC.

3.

Haga clic en Examinar Flash....Una ventana de diálogo de la memoria flash aparece con el
nombre del archivo ingresado automáticamente. Si no aparece el nombre del archivo,
ingréselo manualmente en el campo de nombre del archivo. Haga clic en Aceptar cuando

4.



haya
terminado.

Una vez que se especifican los nombres del archivo local y elarchivo remoto, haga clic en
Cargar
Imagen.

Una ventana de estado aparece mientras que el ASDM escribe la imagen en
Flash.

5.



Una vez finalizada la tarea, aparece la ventana Información que indica una carga
satisfactoria.

Haga clic en Aceptar en la ventana Información y, a continuación, Cerrar en la ventana
Cargar imagen desde PC local.

6.

Elija Configuration > Properties > Device Administration > Boot Image/Configuration para
cambiar el nombre de archivo de Imagen ASDM en la
configuración.

7.



Haga clic en Buscar Flash para elegir o especificar el archivo de imagen ASDM . Luego
haga clic en OK
(Aceptar).

Elija File > Save Running Configuration to Flash para almacenar la configuración en la
memoria
Flash.

8.



Elija Tools > System Reload de la ventana principal para recargar el
dispositivo.

9.

Una nueva ventana aparece que le solicita que verifique los detalles de la recarga. Haga
clic en Guardar la configuración actual en el momento de la recarga y después elija una
fecha y hora de recargar.Ahora - Reinicia el dispositivo inmediatamente.Retraso por -
Especifica los minutos u horas que se necesitan para recargar el dispositivo.Programado

10.



para — Especifica la fecha y hora de la recarga del dispositivo.También puede especificar
si el dispositivo debe forzar una recarga de inmediato si falla la recarga programada. Error
al Comprobar la Recarga fuerza una recarga inmediata después y luego especifica un
tiempo de espera máximo. Ésta es la cantidad de tiempo que el dispositivo de seguridad
espera para notificar otros subsistemas antes de un shutdown o reboot. Después de este
tiempo, se produce un rápido (forzado) shutdown/reboot Haga clic en Programar
Recarga.

Una vez que la recarga está en curso, una ventana de Estado aparece que indica que se
está realizando una recarga. También tiene la opción de salir del ASDM .Nota: Vuelva a
iniciar el ASDM después de que el ASA se
recargue.

11.



Actualización de una Imagen de Software con ASDM 6.x

Nota: El ASDM 6.x se soporta solamente en la imagen de software ASA 8.x y posterior.

Complete estos pasos para actualizar una imagen de software en ASA 5500 con ASDM:

Elija Tools > Upgrade Software desde el equipo local... desde la ventana de inicio del
ASDM.

1.



Elija el tipo de imagen que desea cargar del menú
desplegable.

2.

Haga clic en Examinar archivos locales... o escriba la ruta en el campo Trayectoria de
archivo local para especificar la ubicación de la imagen de software en el PC. La trayectoria
del archivo en el Sistema de Archivos Flash se determina y se muestra automáticamente. Si
la trayectoria del archivo en el Sistema de Archivos Flash no se muestra, puede ingresarla
manualmente o hacer clic en Buscar Flash y elija la
trayectoria.

3.



Una vez especificadas ambas trayectorias del archivo, haga clic en Cargar Imagen. Una
ventana de estado aparece mientras que el ASDM escribe la imagen en
Flash.

4.

Una vez que finalizada esta tarea, aparece una ventana Información que indica una carga
satisfactoria y le solicita establecer esta imagen como imagen de inicio del sistema. Haga
clic en Sí si desea que la nueva imagen se establezca como imagen de inicio de sistema; de
lo contrario, haga clic en
No.

5.

Si hace clic en Sí, la nueva imagen se establece como la imagen de inicio de sistema, y6.



aparece una casilla de información. Click
OK.

Elija Tools > System Reload de la ventana principal para recargar el
dispositivo.

7.

Una nueva ventana aparece que le solicita que verifique los detalles de la recarga. Elija
Guardar la configuración actual en el momento de la recarga , y luego elija la fecha y hora de
la recarga.Ahora - Reinicia el dispositivo inmediatamente.Retraso por - Especifica los
minutos u horas que se necesitan para recargar el dispositivo.Programado para —
Especifica la fecha y hora de la recarga del dispositivo.Puede también especificar si el
dispositivo debe forzar una recarga de inmediato si falla la recarga programada. Error al
Comprobar la Recarga obliga una an recarga inmediata después de, y especifique el tiempo
de espera máximo. Ésta es la cantidad de tiempo que el dispositivo de seguridad espera
para notificar otros subsistemas antes de un shutdown o reboot. Después de este tiempo, se
produce un rápido (forzado) shutdown/reboot Haga clic en Programar

8.



Recarga.

Una vez que la recarga está en curso, una ventana de Estado aparece que indica que se
está realizando una recarga. También tiene la opción de salir del ASDM . Haga clic en Salir
de ASDM , y reinicie el ASDM una vez recargado el
dispositivo.

9.



Actualización de una Imagen de ASDM con ASDM 6.x

Nota: El ASDM 6.x se soporta solamente en la imagen de software ASA 8.x y posterior.

Complete estos pasos para actualizar una Imagen de ASDM en ASA 5500 con ASDM:

Elija Tools > Upgrade Software desde el equipo local... desde la ventana de inicio del
ASDM.

1.



Elija el tipo de imagen que desea cargar del menú
desplegable.

2.

Haga clic en Examinar archivos locales... o escriba la ruta en el campo Trayectoria de
archivo local para especificar la ubicación de la imagen ASDM en su PC. La trayectoria del
archivo en el Sistema de Archivos Flash se determina y se muestra automáticamente. Si la
trayectoria del archivo en el Sistema de Archivos Flash no se muestra, puede ingresarla
manualmente o hacer clic en Buscar Flash y elija la
trayectoria.

3.



Una vez especificadas ambas trayectorias del archivo, haga clic en Cargar Imagen. Una
ventana de estado aparece mientras que el ASDM escribe la imagen en
Flash.

4.

Una vez terminada la tarea, aparece una ventana Información que indica una carga
satisfactoria y le solicita que establezca esta imagen como Imagen de ASDM
predeterminada. Haga clic en Sí si desea que la nueva imagen esté establecida como
Imagen de ASDM; de lo contrario, haga clic en
No.

5.

Si elige sí utilizar la nueva imagen como la Imagen de ASDM, aparece un cuadro de
información. Click

6.



OK.

Haga clic en Guardar en la parte superior de la ventana para guardar la configuración en la
memoria
Flash.

7.

Un cuadro de diálogo aparece para su confirmación. Haga clic en Apply

(Aplicar).

8.

Haga clic en Archivo en la parte superior de la ventana, y elija la Salir para cerrar el
ASDM.

9.



Un cuadro de diálogo puede aparecer que solicita su confirmación. Haga clic en

Sí

10.

Ejecute ASDM otra vez para cargar la nueva Imagen de ASDM.Consulte este vídeo para
obtener más información: Cómo actualizar la imagen de software en un Cisco Adaptive
Security Appliance (ASA) mediante Cisco Adaptive Security Device Manager (ASDM)

11.

Este video publicado en la Comunidad de Soporte de Cisco describe cómo actualizar la imagen
de software en Cisco ASA usando ASDM: Cómo actualizar la imagen de software en un Cisco
Adaptive Security Appliance (ASA) mediante Cisco Adaptive Security Device Manager (ASDM)
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Actualización de una Imagen de Software y una Imagen de
ASDM con CLI

Un servidor TFTP se requiere para actualizar o para instalar una versión anterior de una imagen
del software y una imagen de ASDM para un PIX/ASA. Consulte Selección y Uso del servidor
TFTP para aprender más sobre la selección del servidor TFTP.

El comando copy tftp flash le permite descargar una imagen de software en la memoria Flash de
firewall a través de TFTP. Puede utilizar el comando copy tftp flash con cualquier modelo de
dispositivo de seguridad. La imagen que descarga se pone a disposición del dispositivo de
seguridad en la recarga siguiente (reboot).

Ésta es la salida del comando copy tftp flash:

copy tftp[:[[//location] [/tftp_pathname]]] [[flash/disk0][:[image | asdm]]]

Nota: Para ASA, la palabra clave disk0 reemplaza a flash en el comando copy.

Si el comando se utiliza sin los parámetros optativos de la ubicación o de la cadena de
caracteres, la ubicación y el nombre de archivo se obtienen del usuario de forma interactiva a
través de serie de preguntas similares a las presentadas por el software de Cisco IOS®. Si sólo
ingresa dos puntos,los parámetros se extraen de las configuraciones del comando tftp-server . Si
se proporcionan otros parámetros opcionales, estos valores se usan en lugar de la configuración
del comando tftp-server . Si es un de los los parámetros optativos, tales como los dos puntos y
cualquier carácter después de ellos, el comando se ejecuta sin un prompt para la entrada de
usuario.

La ubicación es una dirección IP o un nombre que se vuelve dirección IP a través del dispositivo

https://supportforums.cisco.com/videos/2353
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de seguridad que nombra el mecanismo de resolución, y actualmente es mapping estático a
través de los comandos name y names . El dispositivo de seguridad debe saber cómo alcanzar
esta ubicación a través de su información de la tabla de ruteo. Esta información es determinada
por la dirección IP, la ruta, o los comandos RIP . Esto depende de su configuración.

La cadena de caracteres puede incluir cualquier nombre de directorio además del componente
más reciente real de la trayectoria al archivo en el servidor. La cadena de caracteres no puede
contener espacios. Si un nombre de directorio tiene espacios establecidos en el directorio en el
servidor TFTP en lugar de en el comando copy tftp flash , y si su servidor TFTP se configura para
señalar a un directorio en el sistema desde el cual descarga la imagen, necesita solamente utilizar
la dirección IP del sistema y del nombre de archivo de la imagen. El servidor TFTP recibe el
comando y determina la ubicación del archivo real de su información de directorio raíz. El servidor
entonces descarga la imagen TFTP al dispositivo de seguridad.

Estos comandos son necesarios actualizar la imagen del software así como la Imagen de ASDM y
convertirla en la imagen boot en la recarga siguiente.

ASA#copy tftp [[flash:/disk0:][software image name/asdm image name]]

!--- Command to set an image as bootup or specify the !--- ASDM image file. ASA(config)#boot

system [flash:/disk0:]/[software image name]

!--- Save active configuration to the Flash. ASA#write memory

!--- Reboot the security appliance and load !--- with the new boot image as per the

configuration file. ASA#reload

Ejemplo:

ASA5510#copy tftp disk0:

Address or name of remote host []? 172.16.31.1

Source filename []? asa722-k8.bin

Destination filename [asa722-k8.bin]?

Accessing tftp://172.16.31.1/asa722-k8.bin...!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Writing file disk0:/asa722-k8.bin...

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

8312832 bytes copied in 163.350 secs (50998 bytes/sec)

ASA5510#show disk0:

-#- --length-- -----date/time------ path

  6 5124096    Jan 01 2003 00:06:22 asa702-k8.bin

  7 5623108    Feb 12 2007 00:23:48 asdm-522.bin

 10 5539756    Feb 12 2007 00:14:18 asdm-521.bin

 11 8294400    Dec 07 2006 05:47:20 asa721-24-k8.bin

 12 6002680    Dec 21 2006 03:58:30 asdm-52034.bin

 13 8312832    Feb 12 2007 22:46:30 asa722-k8.bin

23949312 bytes available (38932480 bytes used)

!--- Command to set "asa722-k8.bin" as the boot image. ASA5510(config)# boot system

disk0:/asa722-k8.bin

!--- Command to set "asdm-522.bin" as the ASDM image. ASA5510(config)# asdm image disk0:/asdm-

522.bin

ASA5510# write memory

ASA5510# reload



Nota: Cuando intenta actualizar la imagen en el ASA desde un servidor FTP, puede utilizar el
comando copy ftp flash. Este comando permite especificar parámetros, como la dirección IP
remota y el nombre del archivo de código fuente. Este procedimiento es similar al TFTP. Sin
embargo, una limitación con es que no puede modificar la interfaz IP/de origen remota (como
puede con TFTP). En el modo TFTP, las opciones especificadas con el comando tftp-server se
pueden extraer y ejecutar. Pero con FTP, no existe esa opción. La interfaz de origen debe ser
siempre la externa de forma predeterminada, que no se puede modificar. Es decir, el servidor FTP
debe ser accesible desde la interfaz externa.

Verificación

Use esta sección para confirmar que su actualización de software es satisfactoria.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos
comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Después de las recargas ASA y de haber iniciado sesión con éxito en el ASDM otra vez, puede
verificar la versión de la imagen que se ejecuta en el dispositivo. Consulte la pestaña General en
la ventana Home para esta información.

Estos comandos CLI se utilizan para verificar la actualización:

Mostrar versión: muestra la imagen actual con la que se inicia el ASA.1.
Show bootvar: Muestra la prioridad de la imagen que se utilizará después de la recarga.2.
Mostrar imagen asdm: muestra la imagen asdm actual utilizada por ASA.3.

Troubleshoot
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Actualmente, no hay información específica de troubleshooting disponible para esta configuración.
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