Introducción
Este documento describe cómo estructurar las configuraciones para configurar el ruteo entre VLAN con el uso de un router externo de Cisco.
Prerequisites
Requirements
Cisco le recomienda que tenga conocimiento acerca de este tema:
- Conocimientos básicos sobre routing
Componentes Utilizados
La información que contiene este documento se basa en estas versiones de software:
- Switch Catalyst Cisco IOS® 15.2E
- Router Cisco Cisco IOS XE 17.3
La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si tiene una red en vivo, asegúrese de entender el posible impacto de cualquier comando.
Convenciones
For more information on document conventions, refer to the Cisco Technical Tips Conventions.
Antecedentes
Este documento describe las configuraciones para configurar el ruteo entre VLAN con el uso de un router externo de Cisco y lo explica con configuraciones de ejemplo en el trunking 802.1Q; los resultados de cada comando se muestran a medida que se ejecutan. En los escenarios presentados en este documento se pueden utilizar diferentes routers de la serie Cisco y cualquier switch Catalyst para obtener los mismos resultados.
Trunking es una forma de llevar el tráfico de varias VLAN a través de un link punto a punto entre dos dispositivos. Al principio, se implementaba el enlace troncal de Ethernet de dos maneras:
Un enlace troncal se crea y se utiliza para transportar tráfico desde dos o más VLAN, por ejemplo, VLAN1 y VLAN2 a través de un único enlace entre switches Catalyst o router Cisco.
El router de Cisco se utiliza para realizar el ruteo entre VLAN-X y VLAN-Y. Esta configuración puede ser útil cuando los switches de la serie Catalyst son de Capa 2 (L2) solamente y no pueden rutear o comunicarse entre las VLAN.
Para 802.1Q trunking, no se etiqueta una VLAN. Esta VLAN se denomina VLAN nativa. La VLAN nativa se usa para tráfico sin etiquetas cuando el puerto está en modo 802.1Q trunking. Al configurar el enlace troncal 802.1Q, recuerde que la VLAN nativa debe configurarse de la misma manera en cada lado del enlace troncal. Un error muy común es que no se haga coincidir las VLAN de origen al configurar el enlace troncal 802.1Q entre el router y el conmutador.
En esta configuración de ejemplo, VLAN 1 es la VLAN nativa, de forma predeterminada, en el router Cisco y en el switch Catalyst. Según las necesidades de la red, puede utilizar una VLAN nativa distinta de la VLAN predeterminada, VLAN1. Los comandos para cambiar la VLAN nativa en estos dispositivos se han mencionado en la sección Configuraciones de este documento.
Las configuraciones de ejemplo presentadas en este documento se pueden utilizar en diferentes series de routers de Cisco que admiten enlaces troncales de VLAN 802.1Q.
Nota: La versión mínima admitida no necesariamente puede ser la versión recomendada. Para determinar la mejor versión de mantenimiento para su producto Cisco, busque los errores enumerados por componente del producto en el Kit de herramientas para errores.
Nota: Solo los usuarios registrados de Cisco tienen acceso a la información, herramientas y documentos internos.
Configurar
En esta sección encontrará la información para configurar las funciones descritas en este documento.
Diagrama de la red
Este documento utiliza la configuración de red que se muestra en el siguiente diagrama.
Diagrama de la redConfiguraciones
Switch Catalyst L2 |
!-- (Optional) Set the IP address and default gateway for VLAN1 for management purposes.
L2_Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
L2_Switch(config)#interface vlan 1
L2_Switch(config-if)#ip address 10.10.0.2 255.255.255.0
L2_Switch(config-if)#no ip directed-broadcast
L2_Switch(config-if)#no ip route-cache
L2_Switch(config-if)#exit
L2_Switch(config-if)#ip default-gateway 10.10.0.1
!-- (Optional) Set the VTP Mode. In our example, we have set the mode to be transparent.
!-- Depending on your network, set the VTP Mode accordingly.
L2_Switch(config)#vtp mode transparent
Setting device to VTP Transparent mode for VLANS.
L2_Switch(config)#
!-- Adding VLAN10 and VLAN11.
L2_Switch(config)#vlan 10-11
L2_Switch(config-vlan)#exit
L2_Switch(config)#
!-- Enable trunking on the interface GigabitEthernet 0/2.
!-- Enter the trunking encapsulation as dot1q.
L2_Switch(config)#interface gigabitEthernet 0/2
L2_Switch(config-if)#switchport trunk encapsulation dot1q
L2_Switch(config-if)#switchport mode trunk
!-- In case of dot1q, you need to make sure that the native VLAN matches across the link.
!-- On Catalyst Switches, by default, the native VLAN is 1.
!-- It is very important that you change the native VLAN on the router accordingly.
!-- The following set of commands can place on the interfaces connecting to the workstations.
L2_Switch(config)#interface gigabitEthernet 0/0
L2_Switch(config-if)#switchport mode access
L2_Switch(config-if)#switchport access vlan 11
L2_Switch(config-if)#exit
L2_Switch(config)#interface gigabitEthernet 0/1
L2_Switch(config-if)#switchport mode access
L2_Switch(config-if)#switchport access vlan 10
L2_Switch(config-if)#exit
!-- Remember to save the configuration.
L2_Switch#write memory
Building configuration... |
Router |
Nota: Las capturas de pantalla siguientes muestran los comandos introducidos en el router de Cisco. Los comentarios entre los comandos están agregados en cursiva para explicar determinados pasos y comandos. Router#configure terminal Enter configuration commands, one per line. End with CNTL/Z.
!-- Select GigabitEthernet 1 for the trunk configuration. !-- No Layer 3 (L3) configuration is done here.
Router (config)#interface GigabitEthernet 1 Router(config-if)#no shut Router(config-if)#exit
!-- Enable dot1q on the sub-interface one for each VLAN.
!-- Configure L3 information on the sub-interface for each gateway.
Router(config)#interface gigabitEthernet 1.10
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 10.10.10.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface gigabitEthernet 1.11
Router(config-subif)#encapsulation dot1Q 11
Router(config-subif)#ip address 10.10.11.1 255.255.255.0
Router(config-subif)#exit
!-- (Optional) For the management VLAN 1 make sure that the native VLAN matches across the link. !-- On the switch, by default, the native VLAN is 1. !-- On the router, configure VLAN1 as the native VLAN.
Router(config)#interface gigabitEthernet 1.1
Router(config-subif)#encapsulation dot1Q 1 native
Router(config-subif)#ip address 10.10.0.1 255.255.255.0
Router(config-subif)#end
!-- Remember to save the configuration.
Router#write memory
Building configuration...
[OK]
Router# Nota: Para que esta configuración funcione y sea posible hacer ping satisfactoriamente entre la estación de trabajo1 y la estación de trabajo2, necesita asegurarse que las gateways predeterminadas en las estaciones de trabajo estén configuradas correctamente. Para la estación de trabajo 1, la puerta de enlace predeterminada debe ser 10.10.11.1 y, para la estación de trabajo 2, 10.10.10.1. |
Comandos útiles
Esta sección lo ayuda a confirmar que su configuración funciona como se espera.
En el switch Catalyst, puede utilizar los siguientes comandos para ayudar con la verificación:
En el router de Cisco, utilice los siguientes comandos:
-
show ip route
-
show interface
Salida de comando de muestra
Catalyst Switch
El siguiente comando se utiliza para verificar el estado administrativo y operativo del puerto. También se usa para garantizar que la VLAN nativa concuerde en ambos lados del trunk. La VLAN nativa se usa para tráfico sin etiquetas cuando el puerto está en modo 802.1Q trunking.
Para el enlace troncal 802.1Q, el comando de resultado muestra:
L2_Switch#show interfaces gigabitEthernet 0/2 switchport
Name: Gi0/2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Protected: false
Appliance trust: none
El siguiente comando se utiliza para verificar que las interfaces (puertos) pertenecen a la VLAN correcta. En este ejemplo, la interfaz Gi0/1 pertenece a VLAN10 y Gi0/0 pertenece a VLAN11. El resto son miembros de VLAN1.
L2_Switch#show vlan brief
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/3
10 VLAN0010 active Gi0/1 11 VLAN0011 active Gi0/0
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
L2_Switch#
El siguiente comando se utiliza para verificar la configuración del VLAN trunking protocol (VTP) en el switch. En este ejemplo, se utiliza el modo transparente. El modo VTP correcto depende de la topología de su red.
L2_Switch#show vtp status
VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name :
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : 5254.0000.8000
Configuration last modified by 0.0.0.0 at 3-1-24 15:21:18
Feature VLAN:
--------------
VTP Operating Mode : Transparent
Maximum VLANs supported locally : 1005
Number of existing VLANs : 7
Configuration Revision : 0
MD5 digest : 0x9F 0x7D 0x8D 0x10 0xB1 0x22 0x2F 0xE7
0x29 0x77 0x42 0xA7 0x95 0xE7 0x68 0x1C
Router Cisco
El siguiente comando indica a la información de ruteo L3 acerca de las subinterfaces configuradas en el router.
Router#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 10.10.0.0/24 is directly connected, GigabitEthernet1.1
L 10.10.0.1/32 is directly connected, GigabitEthernet1.1
C 10.10.10.0/24 is directly connected, GigabitEthernet1.10 L 10.10.10.1/32 is directly connected, GigabitEthernet1.10 C 10.10.11.0/24 is directly connected, GigabitEthernet1.11 L 10.10.11.1/32 is directly connected, GigabitEthernet1.11
El siguiente comando se utiliza para verificar el estado administrativo y operativo de la interfaz. Para el estado de la interfaz del router, el comando de resultado muestra:
Router#show interfaces
GigabitEthernet1 is up, line protocol is up
Hardware is CSR vNIC, address is 5254.0000.004d (bia 5254.0000.004d)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 1000Mbps, link type is auto, media type is Virtual
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:14:10, output hang never
Last clearing of "show interface" counters never
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
5338 packets input, 361563 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
13 packets output, 1248 bytes, 0 underruns
Output 0 broadcasts (0 IP multicasts)
0 output errors, 0 collisions, 2 interface resets
57 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
1 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
GigabitEthernet1.1 is up, line protocol is up
Hardware is CSR vNIC, address is 5254.0000.004d (bia 5254.0000.004d)
Internet address is 10.10.0.1/24
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1.
ARP type: ARPA, ARP Timeout 04:00:00
Keepalive set (10 sec)
Last clearing of "show interface" counters never
GigabitEthernet1.10 is up, line protocol is up Hardware is CSR vNIC, address is 5254.0000.004d (bia 5254.0000.004d) Internet address is 10.10.10.1/24
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 10.
ARP type: ARPA, ARP Timeout 04:00:00
Keepalive set (10 sec)
Last clearing of "show interface" counters never
GigabitEthernet1.11 is up, line protocol is up Hardware is CSR vNIC, address is 5254.0000.004d (bia 5254.0000.004d) Internet address is 10.10.11.1/24
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 11.
ARP type: ARPA, ARP Timeout 04:00:00
Keepalive set (10 sec)
Last clearing of "show interface" counters never
GigabitEthernet2 is administratively down, line protocol is down
Hardware is CSR vNIC, address is 5254.0000.004e (bia 5254.0000.004e)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 1000Mbps, link type is auto, media type is Virtual
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Información Relacionada