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CTC Information and Shortcuts

Note The terms "Unidirectional Path Switched Ring" and "UPSR" may appear in Cisco literature. These terms 
do not refer to using Cisco ONS 15xxx products in a unidirectional path switched ring configuration. 
Rather, these terms, as well as "Path Protected Mesh Network" and "PPMN," refer generally to Cisco's 
path protection feature, which may be used in any topological network configuration. Cisco does not 
recommend using its path protection feature in any particular topological network configuration.

This appendix describes how to navigate in the Cisco Transport Controller (CTC) and change CTC table 
data. It also describes menu and tool options and the shelf inventory data presented in CTC. For 
information about CTC, refer to the “Cisco Transport Controller Operation” chapter in the 
Cisco ONS 15600 Reference Manual.

Display Node, Card, and Network Views
CTC provides three views of the ONS platform:

• Node view appears when you first log into an ONS 15600. This view shows a graphic of the 
ONS 15600 shelf and provides access to tabs and subtabs that you use to manage the node.

• Card view provides access to individual ONS 15600 cards. This view shows a graphic of the card 
and provides access to tabs and subtabs that you use to manage the card.

• Network view shows all the nodes in a ring. A Superuser can set up this feature so each user will see 
the same network view, or the user can create a custom view with maps. This view provides access 
to tabs and subtabs that you use to manage the network.

• Domain view shows all nodes in a selected domain. This view shows nodes that are members of the 
selected domain. Nodes connected to the domain nodes are grayed out.  A domain is used to isolate 
nodes or groups of nodes for easier maintenance.

Table A-1 lists different actions for changing CTC views.
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CTC Window
Different navigational methods are available within the CTC window to access views and perform 
management actions. You can double-click and right-click objects in the graphic area and move the 
mouse over nodes, cards, and ports to view popup status information.

CTC Menu and Toolbar Options
The CTC window menu bar and toolbar provide primary CTC functions. Table A-2 shows the actions 
that are available from the CTC menu and toolbar. 

Table A-1 Change CTC Views

To display: Perform one of the following:

Node view • Log into a node; node view is the default view.

• In network view, double-click a node icon, or right-click the node and 
choose Open Node.

• From the CTC View menu, choose Go To Other Node, then choose the 
node you want from the shortcut menu.

• Use the arrows on the CTC toolbar to navigate up or down views. For 
example, in network view select a node and click the down arrow.

Home view (node 
view of the first node 
you logged into in a 
network)

• From the CTC View menu, choose Go To Home View. 

Domain view • In network view, double-click a domain.

Card view • In node view, double-click a card or right-click the card and choose 
Open Card.

• In node view, single-click a card icon, then select 
Go To Selected Object View from the View menu. 

• Use the arrows on the CTC toolbar to navigate up or down. For example, 
in node view select a card and then click the down arrow.

Network view • In node view, click the up arrow on the CTC toolbar.

• From the View menu, choose Go To Network View.
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Table A-2 CTC Menu and Toolbar Options

Menu Menu Option Toolbar Description

File Add Node Adds a node to the current session. See the “DLP-E28 Add a Node to the 
Current Session or Login Group” task on page 16-43.

Delete Selected 
Node

Deletes a node from the current session. 

Lock CTC Locks CTC without closing the CTC session. A user name and password are 
required to reopen CTC.

Print Prints CTC data. See the “DLP-E214 Print CTC Data” task on page 18-18.

Export Exports CTC data. See the “DLP-E265 Export CTC Data” task on 
page 18-84.

Exit Closes the CTC session. 

The exit icon only appears in the File menu.

Edit Preferences Displays the Preferences dialog box:

• General tab—Allows you to change event defaults and manage 
preferences. 

• Login Node Group tab—Allows you to create login node groups. See the 
“DLP-E27 Create Login Node Groups” task on page 16-41.

• Map—Allows you to customize the network view. See the “DLP-E81 
Change the Network View Background Color” task on page 16-87 and 
the “DLP-E83 Apply a Customer Network View Background” task on 
page 16-88. 

• Circuit—Allows you to change the color of circuit spans. See the 
“DLP-E68 Change Active and Standby Span Color” task on page 16-83.

• Firewall—Sets the Internet Inter-ORB Protocol (IIOP) listener ports for 
access to the ONS 15600 through a firewall. See the “NTP-E94 Set Up 
the ONS 15600 for Firewall Access” procedure on page 4-6.

• JRE—Allows you to select a different Java Runtime Environment (JRE) 
when CTC restarts. 
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View Go To Previous View Displays the previous CTC view.

Go To Next View Displays the next CTC view. Available only after you navigate to a previous 
view. Go to Previous and Go to Next is similar to forward/backward 
navigation in a web browser.

Go To Parent View References the CTC view hierarchy: network view, node view, and card view. 
In card view, this command displays the node view; in node view, the 
command displays network view. Not available in network view.

Go To Selected 
Object View

Displays the object selected in the CTC window.

Go To Home View Displays the login node in node view.

Go To Network View Displays the network view.

Go To Other Node Displays a dialog box allowing you to type in the node name or IP address of 
a a network node that you want to view. 

Show Status Bar — Displays or hides the status bar at the bottom of the CTC window.

Show Tool Bar — Displays or hides the CTC toolbar.

— — Zooms out the network view area (toolbar only).

— — Zooms in the network view area (toolbar only).

— — Zooms in a selected network view area (toolbar only).

Table A-2 CTC Menu and Toolbar Options (continued)

Menu Menu Option Toolbar Description
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Tools Circuits — Displays the following options:

• Repair Circuits—Repairs incomplete circuits following replacement of 
the ONS 15600 alarm interface panel (AIP). Refer to the Cisco ONS 
15600 Troubleshooting Guide for more information.

• Merge Circuits—Merges multiple circuits. See the “NTP-E127 Merge 
Circuits” procedure on page 7-6. 

• Set Path Selector Attributes—Allows you to edit path protection circuit 
path selector attributes. Refer to the “DLP-E127 Edit Path Protection 
Circuit Path Selectors” task on page 17-24.

• Set Circuit State—Allows you to change a circuit state. See the 
“DLP-E188 Change a Circuit Service State” task on page 17-67.

• Roll Circuit—Allows you to reroute live traffic without interrupting 
service. See the “NTP-E55 Bridge and Roll Traffic” procedure on 
page 7-4. 

• Delete Rolls—Removes rolls that are not deleted by CTC after a roll has 
been completed. See the “DLP-E241 Delete a Roll” task on page 18-62.

Overhead Circuits — Displays the Repair IP Tunnels option. Refer to the “NTP-E134 Modify and 
Delete Overhead Circuits” procedure on page 7-3.

Topology Upgrade — Displays the following options:

• Convert UPSR to BLSR (This option does not apply to the 
ONS 15600)—Converts path protection to BLSR.

• Convert Unprotected to UPSR (This option does not apply to the 
ONS 15600)—Converts a point-to-point or linear ADM to path 
protection. 

Manage VLANs — Displays a list of VLANs that have been created and allows you to delete or 
create new VLANs. 

Open TL1 
Connection

Displays the TL1 session dialog box so you can create a TL1 session to a 
specific node. Refer to the Cisco ONS SONET TL1 Command Guide.

Open IOS 
Connection

(Not applicable to ONS 15600.) Displays the Cisco IOS command line 
interface dialog box if a Cisco IOS capable card (ML1000-2 or ML100T-12) 
is installed in the node. Refer to the Ethernet Card Software Feature and 
Configuration Guide.

Help Contents and Index — Displays the online help window. 

User Manuals — Displays the Cisco ONS 15600 documentation.

About CTC — Displays the software version and the nodes in the CTC session. 

Table A-2 CTC Menu and Toolbar Options (continued)

Menu Menu Option Toolbar Description
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CTC Mouse Options
Table A-3 shows mouse navigation techniques in CTC.

— Network Scope — The network scope drop-down list has three options: DWDM, TDM, or All. 
If you choose DWDM, dense wavelength division multiplexing (DWDM) and 
hybrid nodes appear on the network view map. If you choose TDM, time 
division multiplexing (TDM) and hybrid nodes appear on the network view 
map. If you choose All, every node in the network appears on the network 
view map.

— — Opens the CTC Alerts dialog box, which shows the status of certain CTC 
background tasks. When the CTC Alerts toolbar icon contains a red triangle, 
unread notifications exist. When there are no unread notifications, the CTC 
Alerts toolbar icon contains a gray triangle (see the Toolbar column for 
comparison). Notifications include:

• Network disconnection

• Send-PDIP inconsistency—CTC discovers a new node that does not have 
a SEND-PDIP setting consistent with the login node.

• Circuit deletion status—Reports when the circuit deletion process 
completes if you choose “Notify when complete” as described in the 
“DLP-E163 Delete Circuits” task on page 17-49. The CTC Alerts 
window always reports circuit deletion errors. 

• Conditions retrieval error

• Software download failure

You can save a notification by clicking the Save button in the CTC Alerts 
dialog box and navigating to the directory where you want to save the text file. 

By default, the CTC Alerts dialog box opens automatically. To disable 
automatic popup, see the “DLP-E184 Configure the CTC Alerts Dialog Box 
for Automatic Popup” task on page 17-65. 

Table A-2 CTC Menu and Toolbar Options (continued)

Menu Menu Option Toolbar Description
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Table A-3 CTC Mouse Options

Technique Description

Double-click • Node in network view—Displays the node view.

• Domain in network view—Displays the domain view.

• Card in node view—Displays the card view.

• Alarm/Event—Displays the object that raised the alarm or event. 

• Circuits—Displays the Edit Circuit window. 

Right-click • Network view graphic area—Displays a menu that you can use to create a 
new domain, change the position and zoom level of the graphic image, and 
change the background image and color.

• Domain in network view—Displays a mneu that you can use to open a 
domain, show the domain overview, rename the domain, and delete the 
domain.

• Node in network view—Displays a menu where you can open the node, go 
to the node domain, reset the node icon position to the longitude and latitude 
set on the Provisioning > General tabs, provision circuits, and update 
circuits with a new node.

• Span in network view—Displays a menu where you can view information 
about the source and destination ports, the span’s protection scheme, and 
the span’s optical level. You can also display the Circuits on Span dialog 
box, which displays additional span information and allows you to perform 
path protection switching. If a BLSR is provisioned, you can display the 
PCA circuits.

• Card in node view—Displays a menu where you can open, delete, hard and 
soft reset, and change cards. The card you select determines the commands 
that appear.

• Card in card view—Displays a menu that you can use to reset the card, or 
go to the parent view (node view). 

• Empty slot in node view—Displays a menu that allows you to add 
(preprovision) a card.

Move mouse cursor • Over node in network view—Displays a summary of node alarms and 
provides a warning if the node icon has been moved out of the map range.

• Over span in network view—Displays circuit (node, slot, port) bandwidth 
and protection information.

• Over domain in network view—Displays domain name and the number of 
nodes in the domain.

• Over card in node view—Displays card type, card status, highest-level 
alarm, and alarm profile status. The ONS 15600 ASAP card displays the 
Protocol Independent Multicast (PIM) and pluggable port modules (PPM).

• Over card port in node view—Displays port number, port status, and alarm 
profile status.

• Over card port in card view—Displays port state, protection status (if 
applicable), PPM, and alarm profile status. 
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Node View Shortcuts
Table A-4 shows actions on ONS 15600 cards that you can perform by moving your mouse over the CTC 
window.

Network View Shortcuts
Right-click the network view graphic area or a node, span, or domain to display shortcut menus. 
Table A-5 lists the actions that are available from the network view.

Table A-4 Node View Card-Related Shortcuts

Action Shortcut

Display card 
information

Move your mouse over cards in the graphic to display tooltips with the card 
type, card status (active or standby), the highest level of alarm (if any), and the 
alarm profile used by the card.

Open, reset, or delete 
a card

Right-click a card. Choose Open Card to display the card in card view, 
Hard-reset Card to perform a hard reset on the card, Soft-reset Card to 
perform a soft reset of the card, or Delete Card to delete it.

Preprovision a slot Right-click an empty slot. Select the card type you want to provision the slot 
for from the shortcut menu.

Change a card Right-click an OC-N card and choose Change Card. In the Change Card 
dialog box, select the card type. Change card retains all card provisioning.

Change view Right-click on the area outside the node to display a menu that allows you to 
return to the parent view.

Table A-5 Network Management Tasks in Network View

Action Task

Open a node Do any of the following:

• Double-click a node icon.

• Right-click a node icon, and choose Open Node from the shortcut menu.

• Click a node and choose Go To Selected Object View from the CTC View 
menu.

• From the View menu, choose Go To Other Node. Select a node from the 
Select Node dialog box.

• Double-click a node alarm or event in the Alarms or History tabs.

Move a node icon Press the Ctrl key and the left mouse button simultaneously and drag the node 
icon to a new location.

Reset node icon 
position

Right-click a node and choose Reset Node Position from the shortcut menu. 
The node icon moves to the position defined by the longitude and latitude fields 
on the Provisioning > General tabs in node view.

Provision a circuit Right-click a node. From the shortcut menu, choose Provision Circuit To and 
select the node where you want to provision the circuit. For circuit creation 
procedures, see Chapter 6, “Create Circuits.”
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Table Display Options
Table A-6 shows table display options, which include rearranging or hiding CTC table columns and 
sorting table columns by primary or secondary keys (Figure A-1).

Update circuits with 
new node

Right-click a node and choose Update Circuits With New Node from the 
shortcut menu. Use this command when you add a new node and want to pass 
circuits through it.

Display a link 
endpoint

Right-click a span. From the shortcut menu, choose Go To [<node> | <port> | 
<slot>] for the drop port you want to view. CTC displays the card in card view.

Display span 
properties

Do any of the following: 

• Move mouse over a span; the properties appear near the span.

• Click a span; the properties appear in the upper left corner of the window.

• Right-click a span; the properties appear at the top of the shortcut menu.

Perform a path 
protection switch for 
all circuits on a span

Right-click a network span and click Circuits. In the Circuits on Span dialog 
box, switch options appear in the UPSR Span Switching field.

Table A-5 Network Management Tasks in Network View (continued)

Action Task

Table A-6 Table Display Options

Action Click Shortcut Right-Click Shortcut Menu

Resize column Click while dragging the column 
separator to the right or left.

—

Rearrange column order Click while dragging the column 
header to the right or left.

—

Reset column order — Choose Reset Columns 
Order/Visibility.

Hide column — Choose Hide Column.

Display a hidden 
column

— Choose Show Column > 
column-name.

Display all hidden 
columns

— Choose Reset Columns 
Order/Visibility.

Sort table (primary) Click a column header; each click 
changes sort order (ascending or 
descending).

Choose Sort Column.

Sort table (secondary 
sorting keys)

Press the Shift key and 
simultaneously click the column 
header.

Choose Sort Column 
(incremental).
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Figure A-1 Table Shortcut Menu to Customize Table Appearance

Equipment Inventory
In node view, the Inventory tab (Figure A-2) displays ONS 15600 equipment information, including:

• Location—Where the equipment is installed, either chassis or slot number.

• Eqpt Type—The equipment type, for example, FAN_TRAY or OC48_16.

• Admin State—Shows the administrative state of the port. Choosing an administrative state from the 
drop-down list and clicking Apply sets the service state:

– IS places the port in the IS-NR service state.

– IS,AINS places the port in the OOS-AU,AINS service state.

– OOS,DSBLD places the port in the OOS-MA,DSBLD service state.

– OOS,MT places the port in the OOS-MA,MT service state.

Reset sorting — Choose Reset Sorting.

View table row count — View the number after Row 
count=; it is the last item on the 
shortcut menu. Refer to 
Figure A-1 on page A-10.

Table A-6 Table Display Options (continued)

Action Click Shortcut Right-Click Shortcut Menu
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• Service State—Shows the service state of the port:

– IS-NR—In service; able to carry traffic. 

– OOS-AU,AINS—Auto in service; alarm reporting is suppressed, but traffic is carried. When 
ports are in the OOS-AU,AINS service state, the ONS node monitors the ports for an error-free 
signal. When an error-free signal is detected, the port stays in OOS-AU,AINS for the duration 
of the soak period. When the soak period ends, the port service state changes to IS-NR. Raised 
fault conditions, whether or not their alarms are reported, can be retrieved on the 
CTC Conditions tab or by using the TL1 RTRV-COND command. 

– OOS-MA,DSBLD—Out of service; unable to carry traffic. 

– OOS-MA,MT—Out of service, maintenance; alarm reporting is suppressed, but traffic is 
carried and loopbacks are allowed. Raised fault conditions, whether or not their alarms are 
reported, can be retrieved on the CTC Conditions tab or by using the TL1 RTRV-COND 
command.

• Actual Eqpt Type—The actual equipment type, for example, FTA or OC48-LR.

• HW Part #—Hardware part number; this number is printed on the top of the card or equipment piece.

• HW Rev—Hardware revision number.

• Serial #—Equipment serial number; this number is unique to each card.

• CLEI Code—Common Language Equipment Identifier code.

• User Code—A text entry field that allows the user to type a 20-character ASCII code to further 
identify cards.

• Firmware Rev—Revision number of the software used by the application-specific integrated circuit 
(ASIC) chip installed.

• Product ID—Displays the manufacturing product identifier for a hardware component, such as a fan 
tray, chassis, or card. 

• Version ID—Displays the manufacturing version identifier for a fan tray, chassis, or card.
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Figure A-2 Inventory Tab

CTC Data Export
CTC data exported in HTML format can be viewed with any web browser, such as Netscape 
Communicator or Microsoft Internet Explorer. To display the data, use the browser’s File > Open 
command to open the CTC data file. 

CTC data exported as comma separated values (CSV) or tab separated values (TSV) can be viewed in 
text editors, word processors, spreadsheets, and database management applications. Although 
procedures depend on the application, you can typically use File > Open to display the CTC data. Text 
editors and word processors display the data exactly as it is exported. Spreadsheet and database 
management applications display the data in cells. You can then format and manage the data using the 
spreadsheet or database management application tools.

In addition to the CTC exporting, CTC text information can be copied and pasted into other applications 
using the Windows Copy (Ctrl-C), Cut (Ctrl-X), and Paste (Ctrl-V) commands. You can also print CTC 
windows and table data such as alarms and inventory by choosing File > Print. Table A-7 shows the CTC 
tabs and subtabs that contain exportable data.
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Table A-7 Table Data with Export Capability

View or Card Tab Subtab(s)

Network Alarms —

Conditions —

History —

Circuits Circuits, Rolls

Provisioning Alarm Profiles

Maintenance Software

Node Alarms —

Conditions —

History Session, Node

Circuits Circuits, Rolls

Provisioning Network (General, Static Routing, OSPF, Internal Subnet)

Alarm Behavior

Inventory —

Maintenance Software

Audit

Routing Table

Test Access

Alarm Extenders

Logged on User

OC-N Cards Alarms —

Conditions —

History Session, Card

Circuits Circuits, Rolls

Provisioning Line, Threshold, STS, Alarm Behavior

Maintenance Loopback, Transceiver, Protection

Performance —
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