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C H A P T E R 14

Alarm Monitoring and Management

This chapter describes Cisco Transport Controller (CTC) alarm management. To troubleshoot specific 
alarms, refer to the Cisco ONS 15454 Troubleshooting Guide. Chapter topics include:

• Overview, page 1

• Documenting Existing Provisioning, page 1

• Viewing Alarm Counts on the LCD for a Node, Slot, or Port, page 2

• Viewing Alarms, page 3

• Alarm Profiles, page 9

• Suppressing Alarms, page 13

• Provisioning External Alarms and Controls, page 13

• Audit Trail, page 14

14.1 Overview
The CTC detects and reports SONET alarms generated by the Cisco ONS 15454 and the larger SONET 
network. You can use CTC to monitor and manage alarms at the card, node, or network level. Default 
alarm severities conform to the Telcordia GR-253 standard, but you can reset alarm severities in 
customized alarm profiles or suppress CTC alarm reporting. For a detailed description of the standard 
Telcordia categories employed by ONS nodes, refer to the Cisco ONS 15454 Troubleshooting Guide.

Note ONS 15454 alarms can also be monitored and managed through TL1 or a network management system 
(NMS).

14.2 Documenting Existing Provisioning
In the card, node, or network-level CTC view, choose File > Print to print CTC information in graphical 
or tabular form on a Windows-provisioned printer. Choose File > Export to export card, node, or network 
information as editable delineated text files to other applications. Printing and exporting data are useful 
for record keeping or troubleshooting purposes. 
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Print card, node, or network CTC information in graphical or tabular form on a Windows-provisioned 
printer, or export card, node, or network information as editable delineated text files to other 
applications. This feature is useful for viewing the node inventory, circuit routing, or alarm data in 
network record keeping and troubleshooting.

Whether you choose to print or export data, you can choose from the following options:

• Entire frame—Prints or exports the entire CTC window including the graphical view of the card, 
node, or network. This option is available for all windows.

• Tabbed view—Prints or exports the lower half of the CTC window containing tabs and data. The 
printout includes the selected tab (on top) and the data shown in the tab window. For example, if you 
print the History window Tabbed View, you print only history items appearing in the window. This 
option is available for all windows.

• Table contents—Prints or exports CTC data in table format without graphical representations of 
shelves, cards, or tabs. This option is available only for CTC table data, so it does not apply to:

– Provisioning > General, Protection, SNMP, or Timing windows

– Provisioning > Network > General window

– Provisioning > UCP > Node window

– Provisioning > WDM-ANS > Provisioning window (Release 4.5)

– Maintenance > Database, Protection, Diagnostic, or Timing windows

– Maintenance > Cross-Connect > Cards window

The Table Contents option prints all the data contained in a table with the same column headings. 
For example, if you print the History window Table Contents view, you print all data included in the 
table whether or not items appear in the window.

14.3 Viewing Alarm Counts on the LCD for a Node, Slot, or Port
You can view node, slot, or port-level alarm counts and summaries using the buttons on the ONS 15454 
LCD panel. The Slot and Port buttons toggle between display types; the Slot button toggles between 
node display and slot display, and the Port button toggles between slot and port views. Pressing the 
Status button after you choose the display mode will change the display from alarm count to alarm 
summary.

The ONS 15454 has a one-button update for some commonly viewed alarm counts. If you press the Slot 
button once and then wait eight seconds, the display will automatically change from a slot alarm count 
to a slot alarm summary. If you press the Port button to toggle to port-level display, you can use the Port 
button to toggle to a specific slot and to view each port’s port-level alarm count. Figure 14-1 shows the 
LCD panel layout.

Figure 14-1 The LCD Panel
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14.4 Viewing Alarms
In the card, node, or network-level CTC view, click the Alarms tab to display the alarms for that card, 
node, or network. The Alarms window shows alarms in conformance with Telcordia GR-253. This means 
that if a network problem causes two alarms, such as loss of frame (LOF) and loss of signal (LOS), CTC 
only shows the LOS alarm in this window because it supersedes the LOF and replaces it. 

Table 14-1 lists the column headings and the information recorded in each column.

Table 14-2 lists the color codes for alarm and condition severities.

Table 14-1 Alarms Column Descriptions

Column Information Recorded

New Indicates a new alarm. To change this status, click either the Synchronize button or the 
Delete Cleared Alarms button.

Date Date and time of the alarm.

Node Node where the alarm occurred (appears only in network view).

Object TL1 access identifier (AID) for the alarmed object. For an STSmon or VTmon, the 
object.

Eqpt Type Card type in this slot.

Slot Slot where the alarm occurred (appears only in network and node view).

Port Port where the alarm is raised. For STSTerm and VTTerm, the port refers to the upstream 
card it is partnered with.

Sev Severity level: CR (critical), MJ (major), MN (minor), NA (not-alarmed), NR 
(not-reported).

ST Status: R (raised), C (clear)

SA When checked, indicates a service-affecting alarm

Cond The error message/alarm name. These names are alphabetically defined in the “Alarm 
Troubleshooting” chapter of the Cisco ONS 15454 Troubleshooting Guide.

Description Description of the alarm.

Num An incrementing count of alarm messages. 

Ref The reference number assigned to the alarm.

Table 14-2 Color Codes for Alarms and Conditions

Color Description

Red Raised Critical (CR) alarm

Orange Raised Major (MJ) alarm

Yellow Raised Minor (MN) alarm

Magenta Raised Not-Alarmed (NA) condition

Blue Raised Not-Reported (NR) condition

White Cleared (C) alarm or condition
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Release 4.1 and 4.5 have TL1 port-based alarm numbering that identifies an alarmed STS or VT by its 
STS on a port rather than the STS on the optical card. The numbering is present in the STS alarm 
(STSTerm and STSMon) and VT alarm (VTTerm and VTMon) TL1 access identifier (AID). Table 14-3 
lists the object numbering schemes for MON and TERM objects.

14.4.1 Viewing Alarms With Each Node’s Time Zone
By default, alarms and conditions are displayed with the time stamp of the CTC workstation where you 
are viewing them. But you can set the node to report alarms (and conditions) using the time zone where 
the node is located by clicking Edit > Preferences, and clicking the Display Events Using Each Node’s 
Timezone check box.

14.4.2 Controlling Alarm Display
You can control the display of the alarms shown on the Alarms window. Table 14-4 shows the actions 
you can perform in the Alarms window.

Table 14-3 TL1 Port-Based Alarm Numbering Scheme

Object STS or VT AID Port No.

MON
object

STS-<Slot>-<Port>-<STS>
For example, STS-6-1-6

VT1-<Slot>-<Port>-<STS>-
<VT Group>-<VT>
For example, VT1-6-1-6-1-1

Port=1

TERM
object

<Upstream Slot>-<Port>-<STS>
For example, STS-6-3-6 

<Upstream Slot>-<Port>-<STS>-
<VT Group>-<VT>
For example, VT1-6-3-6-1-1 

Port=1

Table 14-4 Alarm Display

Button Action

Filter Allows you to change the display on the Alarms window to show only 
alarms that meet a certain severity level, occur in a specified time frame, 
and/or reflect specific conditions. For example, you can set the filter so that 
only critical alarms display on the window.

If you enable the Filter feature by clicking the Filter icon button in one CTC 
view, such as node view, it is enabled in the others as well (card view and 
network view).

Synchronize Updates the alarm display. Although CTC displays alarms in real time, the 
Synchronize button allows you to verify the alarm display. This is 
particularly useful during provisioning or troubleshooting.

Delete Cleared Alarms Deletes alarms that have been cleared.
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14.4.3 Viewing Alarm-Affected Circuits
A user can view which ONS 15454 circuits are affected by a specific alarm by positioning the cursor 
over the alarm in the Alarm window and right-clicking. A shortcut menu is displayed (Figure 14-2). 
When the user selects the Select Affected Circuits option, the Circuits window opens to show the circuits 
that are affected by the alarm (Figure 14-3 on page 14-6).

Figure 14-2 Select Affected Circuits Option

AutoDelete Cleared 
Alarms

If checked, CTC automatically deletes cleared alarms.

Filter tool Enables or disables alarm filtering in the card, node, or network view. When 
enabled or disabled, this state applies to other views for that node and for 
all other nodes in the network. For example, if the Filter tool is enabled in 
the node (default login) view Alarms window, the network view Alarms 
window and card view Alarms window also show the tool enabled. All other 
nodes in the network also show the tool enabled.

Table 14-4 Alarm Display (continued)

Button Action
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Figure 14-3 Viewing Alarm-Affected Circuits

The alarm display can be filtered to keep particular alarm severities, or alarms that occur between certain 
dates, from appearing in the Alarms window (Figure 14-2 on page 14-5). You can set the parameters of 
the filter by clicking the Filter button at the bottom-left of the Alarms window. You can turn the filter on 
or off by clicking the Filter icon button at the bottom-right of the window. CTC retains your filter 
activation setting. For example, if you turn the filter on and then log out, CTC makes the filter active the 
next time your user ID is activated.

14.4.4 Conditions Tab
The Conditions window displays retrieved fault conditions. A condition is a fault or status detected by 
ONS 15454 hardware or software. When a condition occurs and continues for a minimum period, CTC 
raises a condition, which is a flag showing that this particular condition currently exists on the 
ONS 15454. 

The Conditions window shows all conditions that occur, including those that are superseded. For 
instance, if a network problem causes two alarms, such as LOF and LOS, CTC shows both the LOF and 
LOS conditions in this window. Having all conditions visible can be helpful when troubleshooting the 
ONS 15454. If you want to retrieve conditions that obey a root-cause hierarchy (that is, LOS supersedes 
and replaces LOF), you can exclude the same root causes by checking a check box in the window.

Fault conditions include reported alarms and not-reported or not-alarmed conditions. Refer to the trouble 
notifications information in the Cisco ONS 15454 Troubleshooting Guide for more information about 
alarm and condition classifications.

14.4.5 Controlling the Conditions Display
You can control the display of the conditions on the Conditions window. Table 14-5 on page 14-7 shows 
the actions you can perform in the window.
14-6
Cisco ONS 15454 Reference Manual, R4.1.x and 4.5

February 2004



Chapter 14      Alarm Monitoring and Management
Viewing Alarms
14.4.5.1 Retrieve and Display Conditions

The current set of all existing conditions maintained by the alarm manager can be seen when you click 
the Retrieve button. The set of conditions retrieved is relative to the view. For example, if you click the 
button while displaying the node view, node-specific conditions are displayed. If you click the button 
while displaying the network view, all conditions for the network (including ONS 15454 nodes and other 
connected nodes such as ONS 15454) are displayed, and the card view shows only card-specific 
conditions.

You can also set a node to display conditions using the time zone where the node is located, rather than 
the time zone of the PC where they are being viewed. See the “Viewing Alarms With Each Node’s Time 
Zone” section on page 4 for more information.

14.4.5.2 Conditions Column Descriptions

Table 14-6 lists the Conditions window column headings and the information recorded in each column.

Table 14-5 Conditions Display

Button Action

Retrieve Retrieves the current set of all existing fault conditions, as maintained by 
the alarm manager, from the ONS 15454.

Filter Allows you to change the Conditions window display to only show the 
conditions that meet a certain severity level or occur in a specified time. For 
example, you can set the filter so that only critical conditions display on the 
window.

There is a Filter icon button on the lower-right of the window that allows 
you to enable or disable the filter feature.

Table 14-6 Conditions Column Description

Column Information Recorded

New Indicates a new condition.

Date Date and time of the condition.

Object TL1 access identifier (AID) for the condition object. For an STSmon or VTmon, the 
object.

Eqpt Type Card type in this slot.

Slot Slot where the condition occurred (appears only in network and node view)

Port Port where the condition occurred. For STSTerm and VTTerm, the port refers to the 
upstream card it is partnered with.

Sev1 Severity level: CR (critical), MJ (major), MN (minor), NA (not-alarmed), NR 
(not-reported).

SA1 Indicates a service-affecting alarm (when checked).

Cond The error message/alarm name; these names are alphabetically defined in the “Alarm 
Troubleshooting” chapter of the Cisco ONS 15454 Troubleshooting Guide.
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14.4.6 Viewing History
The History window displays historical alarm data. It also displays conditions, which are not-alarmed 
activities such as timing changes and threshold crossings. For example, protection-switching events or 
performance-monitoring threshold crossings appear here. The ONS 15454 can store up to 640 critical 
alarm messages, 640 major alarm messages, 640 minor alarm messages, and 640 condition messages. 
When any of these limits is reached, the ONS 15454 discards the oldest events in that category.

Note In the Preference dialog General tab, the Maximum History Entries value only applies to the Session 
window.

• The History > Session window is shown in network view, node view, and card view. It shows alarms 
and conditions that occurred during the current user CTC session. 

• The History > Node window is only shown in node view. It shows the alarms and conditions that 
occurred on the node since CTC software was operated on the node. 

• The History > Card window is only shown in card view. It shows the alarms and conditions that 
occurred on the card since CTC software was installed on the node. 

Tip Double-click an alarm in the History window to display the corresponding view. For example, 
double-clicking a card alarm takes you to card view. In network view, double-clicking a node alarm takes 
you to node view.

14.4.6.1 History Column Descriptions

Table 14-7 lists the History window column headings and the information recorded in each column.

Description Description of the condition.

Node Node where the alarm occurred (appears only in network view).

1. All alarms, their severities, and service-affecting statuses are also displayed in the Condition tab unless you choose to filter 
the alarm from the display using the Filter button.

Table 14-6 Conditions Column Description (continued)

Column Information Recorded

Table 14-7 History Column Description

Column Information Recorded

Date Date and time of the condition.

Object TL1 access identifier (AID) for the condition object. For an STSmon or VTmon, the 
object.

Sev Severity level: critical (CR), major (MJ), minor (MN), not-alarmed (NA), not-reported 
(NR).

Eqpt Type Card type in this slot (only displays in network view and node view).

ST Status: raised (R), cleared (C), or transient (T).

Description Description of the condition.
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14.4.6.2 Retrieve and Display Alarm and Condition History

You can retrieve and view the history of alarms and conditions, as well as transients (passing 
notifications of processes as they occur) in the CTC history window. The information in this window is 
specific to the view where it is shown (that is, network history in the network view, node history in the 
node view, and card history in the card view). 

The node and card history views are each divided into two tabs. In node view, when you click the 
Retrieve button, you can see the history of alarms, conditions, and transients that have occurred on the 
node in the History > Node window, and the history of alarms, conditions, and transients that have 
occurred on the node during your login session in the History > Session window. In the card-view history 
window, once you retrieve the card history, you can see the history of alarms, conditions, and transients 
on the card in the History > Card window, or a history of alarms, conditions, and transients that have 
occurred during your login session in the History > Session window.

You can also filter the severities and occurrence period in these history windows, but you cannot filter 
out not-reported conditions or transients.

14.5 Alarm Profiles
The alarm profiles feature allows you to change default alarm severities by creating unique alarm profiles 
for individual ONS 15454 ports, cards, or nodes. A created alarm profile can be applied to any node on 
the network. Alarm profiles can be saved to a file and imported elsewhere in the network, but the profile 
must be stored locally on a node before it can be applied to the node, its cards, or its cards’ ports. 

CTC can store up to ten active alarm profiles at any time to apply to the node. Custom profiles can take 
eight of these active profile positions, and two are reserved by CTC. The reserved Default profile 
contains Telcordia GR-253-CORE severities. The reserved Inherited profile allows port alarm severities 
to be governed by the card-level severities, or card alarm severities to be determined by the node-level 
severities.

If one or more alarm profiles have been stored as files from elsewhere in the network onto the local PC 
or server hard drive where CTC resides, you can utilize as many profiles as you can physically store by 
deleting and replacing them locally in CTC so that only eight are active at any given time.

Port Port where the condition occurred. For STSTerm and VTTerm, the port refers to the 
upstream card it is partnered with.

Cond Condition name.

Slot Slot where the condition occurred (only displays in network view and node view).

SA Indicates a service-affecting alarm (when checked).

Table 14-7 History Column Description (continued)

Column Information Recorded
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14.5.1 Creating and Modifying Alarm Profiles
Alarm profiles are created in the network view using the Provisioning > Alarm Profiles tabs. Figure 14-4 
shows the default list of alarm severities. A default alarm profile (in the Default column) is 
preprovisioned for every alarm. After loading the default profile on the node, you can use the Clone 
feature to create profiles based upon the default alarm profile. After the new profile is created, the Alarm 
Profiles window shows the default profile and the new profile.

Note The alarm profile list contains a master list of alarms that is used for a mixed node network. Some of 
these alarms may not be used in all ONS nodes.

Figure 14-4 Network View Alarm Profiles Window

14.5.2 Alarm Profile Buttons
The Alarm Profiles window displays six buttons on the right side. Table 14-8 lists and describes each of 
the alarm profile buttons and their functions. 

Table 14-8 Alarm Profile Buttons

Button Description

Load Loads a profile to a node or a file.

Store Saves profiles on a node (or nodes) or in a file.

Delete Deletes profiles from a node.
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14.5.3 Alarm Profile Editing
Table 14-9 lists and describes the five profile-editing options available when you right-click an alarm 
item in the profile column (such as Default). 

14.5.4 Alarm Severity Options
To change or assign alarm severity, left-click the alarm severity you want to change in the alarm profile 
column. Seven severity levels appear for the alarm:

• Not-reported (NR)

• Not-alarmed (NA)

• Minor (MN)

• Major (MJ) 

• Critical (CR)

• UNSET: Unset/Unknown (not normally used)

• Transient (T)

Transient and Unset only appear in alarm profiles. They do not appear when you view alarms, history, 
or conditions. 

Compare Displays differences between alarm profiles (for 
example, individual alarms that are not 
configured equivalently between profiles).

Available Displays all profiles available on each node.

Usage Displays all entities (nodes and alarm subjects) 
present in the network and which profiles contain 
the alarm. Can be printed.

Table 14-8 Alarm Profile Buttons (continued)

Button Description

Table 14-9 Alarm Profile Editing Options

Button Description

Store Saves a profile in a node or in a file.

Rename Changes a profile name.

Clone Creates a profile that contains the same alarm severity settings 
as the profile being cloned.

Reset Restores a profile to its previous state or to the original state (if 
it has not yet been applied).

Remove Removes a profile from the table editor.
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14.5.5 Row Display Options
In the network view, the Alarm Profiles window displays two check boxes at the bottom of the window:

• Hide reference values—Highlights alarms with non-default severities by clearing alarm cells with 
default severities (currently disabled in Release 4.5).

• Hide identical rows—Hides rows of alarms that contain the same severity for each profile. 

14.5.6 Applying Alarm Profiles
In CTC node view, the Alarm Behavior window displays alarm profiles for the node. In card view, the 
Alarm Behavior window displays the alarm profiles for the selected card. Alarm profiles form a 
hierarchy. A node-level alarm profile applies to all cards in the node except cards that have their own 
profiles. A card-level alarm profile applies to all ports on the card except ports that have their own 
profiles.

At the node level, you can apply profile changes on a card-by-card basis or set a profile for the entire 
node. At the card-level view, you can apply profile changes on a port-by-port basis or set alarm profiles 
for all ports on that card. Figure 14-5 shows the E100-2 card view of an alarm profile.

Figure 14-5 Card View of an E100-2 Card Alarm Profile
14-12
Cisco ONS 15454 Reference Manual, R4.1.x and 4.5

February 2004



Chapter 14      Alarm Monitoring and Management
Suppressing Alarms
14.6 Suppressing Alarms
ONS 15454 nodes that support Release 4.1 have alarm suppression options that keep node, slot, chassis, 
or port alarms from being displayed in the Alarms window. Suppression changes the entity alarm to 
Not-Reported, so suppressed alarms are shown in the Conditions window. The suppressed alarms are 
displayed with their other visual characteristics (service-affecting status and color-coding) in the 
window. These alarms do not appear in the History window or in any other clients. 

In node view, you can suppress all alarms for a node, one or more card slots, fan slots, or non-card objects 
such as the chassis by clicking the Provisioning > Alarm Behavior tabs and clicking the Suppress Alarms 
check box. In the card view, you can suppress alarms on a port-by-port basis. All alarms for the entity 
are suppressed. For example, if you click the Suppress Alarms check box in node view, all node alarms 
appear in the Conditions window rather than the Alarms window. If you suppress alarms for one or more 
slots or ports, alarms for those entities appear in the Conditions window.

Note Use alarm suppression with caution. If multiple CTC or TL1 sessions are open, suppressing the alarms 
in one session suppresses the alarms in all other open sessions.

14.7 Provisioning External Alarms and Controls
External alarm inputs can be provisioned on the AIC or AIC-I cards for external sensors such as an open 
door and flood sensors, temperature sensors, and other environmental conditions. External control 
outputs on these two cards allow you to drive external visual or audible devices such as bells and lights. 
They can control other devices such as generators, heaters, and fans.

You provision external alarms in the AIC card view Provisioning> External Alarms tab and controls in 
the AIC card view Provisioning > External Controls tab. Up to 4 external alarm inputs and 4 external 
controls are available with the AIC card. Up to 12 external alarm inputs and 4 external controls are 
available with the AIC-I card. If you also provision the alarm extension panel (AEP) with the AIC-I, 
there are 32 inputs and 16 outputs. 

14.7.1 External Alarm Input
You can provision each alarm input separately. Provisionable characteristics of external alarm inputs 
include:

• Alarm type

• Alarm severity (CR, MJ, MN, NA, and NR)

• Alarm-trigger setting (open or closed)

• Virtual wire associated with the alarm

• CTC alarm log description (up to 63 characters)

14.7.2 External Control Output
You can provision each alarm output separately. Provisionable characteristics of alarm outputs include:

• Control type.
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• Trigger type (alarm or virtual wire).

• Description for CTC display.

• Closure setting (manually or by trigger). If you provision the output closure to be triggered, the 
following characteristics can be used as triggers:

• Local NE alarm severity—A chosen alarm severity (for example, major) and any higher-severity 
alarm (in this case, critical) causes output closure.

• Remote NE alarm severity—Similar to local NE alarm severity trigger setting, but applies to 
remote alarms.

• Virtual wire entities—You can provision an alarm that is input to a virtual wire to trigger an 
external control output.

14.8 Audit Trail
The ONS 15454 keeps a human-readable audit trail of all system actions, such as circuit creation or 
deletion, and security events such as login and log outs. You can archive this log in text form on a PC or 
network. You can access the log by clicking the Maintenance > Audit tabs. The log capacity is 640 
entries; when this limit is reached, the oldest entries are overwritten with new events. When the log is 
80% full, an AUD-LOG-LOW condition is raised. When the log is full and entries are being overwritten, 
an AUD-LOG-LOSS condition occurs.

This window contains the columns listed in Table 14-10.

Table 14-10 Audit Trail Window Columns

Heading Explanation

Date Date when the action occurred

Num Incrementing count of actions

User User ID that initiated the action

P/F Pass/Fail (that is, whether the action was or was not executed)

Operation Action that was taken
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