Create Windows CA Certificate Templatesfor
CUCM
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This document describes a step-by-step procedure to create certificate templates on Windows Server-based
Certification Authorities (CA).

Prerequisites
Requirements

Cisco recommends that you have knowledge of these topics:

* CUCM version 11.5(1).
» Basic knowledge of Windows Server administration

Components Used

The information in this document is based on these software and hardware versions:

« CUCM Version 11.5(1).
* Microsoft Windows Server 2012 R2 with CA servicesinstalled.

The information in this document was created from the devices in a specific lab environment. All of the
devices used in this document started with a cleared (default) configuration. If your network islive, ensure
that you understand the potential impact of any command.

Background information

These certificate templates are compliant with X.509 extension requirements for every type of Cisco Unified



Communications Manager (CUCM) certificate.

There are five types of certificates that can be signed by an external CA:

Certificate Use Impacted Services
Presented at secure device registration .
and can sign Certificate Trust List + Cisco Call Manager
(CTL)/Internal Trust List (ITL) files, | ~
Callmanager used for secure interactions with other Cisco CTI Manager
servers such as secure Session . Cisco TETP
Initiation Protocol (SIP) Trunks.
- Cisco Tomcat
Presented for Secure Hypertext - Single Sign-On (SSO)
tomcat Transfer Protocol (HTTPS)
Interactions. - Extension Mobility
- Corporate Directory
Used for backup file generation, as . .
ipsec well as | P Security (IPsec) interaction | Cisco DRF Primary
with Media Gateway Control Protocol | ~
(MGCP) or H323 gateways. Cisco DRF Local
CAPE Used to generate Locally Significant |- Cisco Certificate Authority Proxy
Certificates (LSC) for phones. Function
Used to create a connection to the Trust
TVS Verification Service (TVS) When the |, Cisco Trust Verification Service
phones are not able to authenticate an
unknown certificate.

% Note: ipsec certificate is not related to Cisco DRF Primary and Cisco DRF Local since 14, in newer
versions, Tomcat certificate is used instead. There is no plan to add this changeto 12.5 or earlier
versions.

Each of these certificates has some X.509 extension requirements that need to be set, otherwise, you can
encounter misbehavior on any of the aforementioned services.

Certificate X.509 Key Usage X.509 Extended Key Usage

Callmanager | Digital Signature |- Web Server Authentication




- Key Encipherment |- Web Client Authentication

- Data Encipherment

- Digital Signature
- Web Server Authentication
tomcat - Key Encipherment
- Web Client Authentication
- Data Encipherment

- Digital Signature |- Web Server Authentication
ipsec - Key Encipherment |- Web Client Authentication

- Data Encipherment |- IPsec End System

- Digital Signature
- Web Server Authentication
CAPF - Certificate Sign
- Web Client Authentication
- Key Encipherment

- Digital Signature
- Web Server Authentication
TVS - Key Encipherment
- Web Client Authentication
- Data Encipherment

For more information, reference the Security Guide for Cisco Unified Communications Manager

Configure

Step 1. On the Windows Server, navigate to Server Manager > Tools > Certification Authority, as shown
in the image.


https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/security/12_5_1/cucm_b_security-guide-1251/cucm_b_security-guide-1251_chapter_011101.html?bookSearch=true#reference_0084C33783A0CE6C8A1097015629BEF7
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Step 2. Select your CA, then navigate to Certificate Templates, right-click on the list and select M anage,
as shown in the image.
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The next images display only the creation of the CallManager template; but the same steps can be followed
to create the certificate templates for the Tomcat and the TV S services. The only differenceis to ensure the
respective service name is used for each new template in step 2.

Step 1. Find the Web Server template, right-click on it and select Duplicate Template, as shown in the
image.
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Step 2. Under General, you can change the certificate template's name, display name, validity, and some
other variables.



|| Do not automatically neenroll i a duplicate centficate eists in Active
~ Dwectory




Step 3. Navigate to Extensions > Key Usage > Edit, as shown in the image.
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Step 4. Select these options and select OK, as shown in the image.

* Digital signature
» Allow key exchange only with key encryption (key encipher ment)
» Allow encryption of user data
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Step 5. Navigate to Extensions > Application Policies > Edit > Add, as shown in the image.



Compatibity | General | Request Handing | Cryptography | Key Attestation

Subject Name | Server | Issuance Feguirments

Superseded Templates Bensons

To modify an edension, select . and then chick Bdt,

Security




Step 6. Search for Client Authentication, select it and select OK on both this window and the previous one,
as shown in the image.



An applcation poley (callad anhancad key usage in Windows 2000)
defines how & cerificate can be used. Select the application polcy requined
i vl sigriatures of Cortificates issued by this bemplate.

ok || Caodl |[ soev || Heo

Step 7. Back on the template, select Apply and then OK.



To modiy an extension, select i, and then chek Bt




Step 8. Close the Certificate Template Console window, and back on the very first window, navigate to
New > Certificate Templateto I ssue, as shown in the image.
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Step 9. Select the new CallM anager CUCM template and select OK, as shown in the image.
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Step 10. Repeat al previous steps to create certificate templates for the Tomcat and TV S services as needed.

| Psec Template

Step 1. Find the Web Server template, right-click on it and select Duplicate Template, as shown in the

image.
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Step 2. Under General, you can change the certificate template’ s name, display name, validity, and some

other vairiables.
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Step 3. Navigate to Extensions > Key Usage > Edit, as shown in the image.
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Step 4. Select these options and select OK, as shown in the image.

* Digital signature
» Allow key exchange only with key encryption (key encipher ment)
» Allow encryption of user data
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Step 5. Navigate to Extensions > Application Policies > Edit > Add, as shown in the image.
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Subject Name |

Issuance Requirements

Superseded Templates

Enmnnru | Secudy

To modify an edension, sslect &, and then cick EdR.




Step 6. Search for Client Authentication, select it and then OK, as shown in the image.
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L wi? [ Lo L pmr |. A Pl mrererd

A appheation pobey (caled snhanced key usages in Windows J000)
defries how a cerdficate can be used. Select the apphcation pobcy requined
Fowr wiplhd mignatures of cerbificales issued by this template.




Step 7. Select Add again, search for | P security end system, select it and then select OK on this and on the
previous window as well.



An apphcation pobcy fcalled enhanced key usage n 'Windows 2000)
defines how a cetficate can be used. Select the apphcation pobcy required
For walbd sgnatures of certfcabes msond by this termplate
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Step 8. Back on the template, select Apply and then OK, as shown in the image.
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Step 9. Close the Certificate Templates Console window, and back on the very first window, navigate to
New > Certificate Templateto I ssue, as shown in the image.
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Step 10. Select the new IPSEC CUCM template and select OK, as shown in the image.
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Al of the cetficabe templates in the organcaton may not be svalabls to your CA

For more iformaticn, see Certificate Ternplpte Concepts,

CAPF Template

Step 1. Find the Root CA template and right-click on it. Then select Duplicate Template, as shownin the
image.
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Step 2. Under General, you can change the certificate template’ s name, display name, validity, ans some
other variables.
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Step 3. Navigate to Extensions > Key Usage > Edit, as shown in the image.
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To modify an extension, selact 1. and then cick Edit.

Step 4. Select these options and select OK,, as shown in the image.



 Digital signature
* Certificate signing
* CRL signing
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Step 5. Navigate to Extensions > Application Policies > Edit > Add, as shown in the image.



Compatibity | General | Request Handing | Cryptography | Key Attestation

Subject Name | Server | Issuance Feguirments

Superseded Templates Bensons

To modify an edension, select . and then chick Bdt,

Security




Step 6. Search for Client Authentication, select it and then select OK, as shown in the image.
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Step 7. Select Add again, search for | P security end system, select it and then select OK on this and on the
previous window as well, as shown in the image.
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Step 8. Back on the template, select Apply and then OK, as shown in the image.
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Step 9. Close the Certificate Templates Console window, and back on the very first window, navigate to
New > Certificate Templateto I ssue, as shown in the image.
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Step 10. Select the new CAPF CUCM template and select OK, as shown in the image.
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Generate a Certificate Signing Request

Use this example in order to generate a CallManager certificate with the use of the newly created templ ates.
The same procedure can be used for any certificate type, you just need to select the certificate and template
types accordingly:

Step 1. On CUCM, navigate to OS Administration > Security > Certificate Management > Gener ate
CSR.

Step 2. Select these options and select Gener ate, as shown in the image.

* Certificate Purpose: CallM anager
 Distribution: <Thiscan either bejust for one server or Multi-SAN>
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Step 3. A confirmation message is generated, as shown in the image.
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Step 4. On the certificate list, look for the entry with type CSR Only and select it, as shown in the image.
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-Certificate Settings
File Hame CallManager.csr
Certificibe Purpois CallMandger
Cartificate Type carts
Certificyte Growp product-£m

Description(friendly name)

~Coertificate File Data

PECSID Reguast: | =
wErsion: O
Subject: OH=115FU08-ms. maucaballab, OU=dsco, O=clsto. Leclsoo, ST=olson, C= HX
SubjectPeinfo: RSA [1.2.840,11354%9.1.1.1)
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=S T de0E 322 6bsab 0 SEThTIOZ 735 368 edeesd 71 3062 7d 75b0c 0w 1e L 4 S5E2 360811 ShEC
EDISaTeB4cd 0001 00
Attribates: [

Regquested Extensions | #

Delete Downlosd CSR

Step 6. On your browser, navigate to this URL, and enter your domain controller administrator credentials:
https://<your WindowsSer ver | P>/certsrv/.

Step 7. Navigate to Request a certificate > advanced certificate request, as shown in the image.
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Step 8. Open the CSR file and copy all its contents:

Pl [E Fomat Vs baip
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Step 9. Paste the CSR in the Base-64-encoded certificate request field. Under Certificate Template, select
the correct template and select Submit, as shown in the image.
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Step 10. Finally, select Base 64 encoded and Download certificate chain. The generated file can now be
uploaded to the CUCM.
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Verify
The verification procedure is actually part of the configuration process.

Troubleshoot

Thereis currently no specific troubleshoot information available for this configuration.



