Introduction
This document describes how to configure router on a stick with a CGR2010 and Cisco Ethernet Switch Module (ESM).
Prerequisites
Requirements
Cisco recommends that you have knowledge of these topics:
- Routing and Switching fundamentals
- CGR2010 and ESM architecture.
- CGR2010 must run Cisco IOS Release 15.1(4)M or higher in order to run the switch module.
Components Used
The information in this document is based on this hardware/software versions CGR2010 with Cisco IOS Release 15.1(4)M
The outputs in this document were taken from devices in a specific lab environment. All devices used in this document started with a cleared (default) configuration. If your network is live, ensure that you understand the potential impact of any command.
Configure
ESM Module:
!- - Default configuration - -!
interface Port-channel48
description Internal backplane interface. Use caution while changing the configuration
switchport mode trunk
end
interface Vlan33
ip address 192.168.33.33 255.255.255.0
interface Vlan44
ip address 192.168.44.44 255.255.255.0
interface Vlan55
ip address 192.168.55.55 255.255.255.0
Exit the ESM module. Press the key combination: ctrl + shift + 6 and then x .
Write discconect to finish the ESM session.
CGR2010 configuration :
interface GigabitEthernet0/0/0.33
encapsulation dot1Q 33
ip address 192.168.33.1 255.255.255.0
end
interface GigabitEthernet0/0/0.44
encapsulation dot1Q 44
ip address 192.168.44.1 255.255.255.0
end
interface GigabitEthernet0/0/0.55
encapsulation dot1Q 55
ip address 192.168.55.1 255.255.255.0
end
Verify
Perform some pings from ESM to CGR2010 virtual interfaces:
Ping to 192.168.55.1 from all the SVI sources.
Switch#ping 192.168.55.1 source vlan 33
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.55.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.33.33
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
Switch#ping 192.168.55.1 source vlan 44
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.55.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.44.44
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
Switch#ping 192.168.55.1 source vlan 55
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.55.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.55.55
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms
Ping to 192.168.33.1 from all the SVI sources.
Switch#ping 192.168.33.1 source vlan 33
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.33.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.33.33
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/203/1007 ms
Switch#ping 192.168.33.1 source vlan 44
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.33.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.44.44
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
Switch#ping 192.168.33.1 source vlan 55
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.33.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.55.55
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
Related Information
CGR2010 Requirements
ESM Port-Channel48