Einleitung
In diesem Dokument wird beschrieben, wie Sie ein Problem beheben, das durch persistente Registrierungsschlüssel verursacht wird, wenn Sie Cisco Jabber für Windows installieren oder aktualisieren.
Voraussetzungen
Anforderungen
Cisco empfiehlt, über Kenntnisse in folgenden Bereichen zu verfügen:
- Cisco Jabber für Windows
- Microsoft Windows 7-Betriebssystem (32- und 64-Bit)
- Betriebssystem Microsoft Windows Version 10 (32- und 64-Bit)
Verwendete Komponenten
Dieses Dokument ist nicht auf bestimmte Hardware- oder Softwareversionen beschränkt.
Die Informationen in diesem Dokument beziehen sich auf Geräte in einer speziell eingerichteten Testumgebung. Alle Geräte, die in diesem Dokument benutzt wurden, begannen mit einer gelöschten (Nichterfüllungs) Konfiguration. Wenn Ihr Netz Live ist, überprüfen Sie, ob Sie die mögliche Auswirkung jedes möglichen Befehls verstehen.
Problem
Wenn Sie versuchen, Cisco Jabber für Windows Version 9.x oder höher zu installieren oder zu aktualisieren, schlägt der Versuch fehl, und Sie erhalten die folgende Fehlermeldung:
Error 1714. The older version of Cisco Jabber cannot be removed. Contact your technical Support team
Ursache
Die Programme, die über die MSI-Datei (Microsoft Installer) installiert werden, enthalten einen Eintrag im Deinstallationsschlüssel mit einem Windows Installer-Wert von einem (1). Wenn die Funktion Software auf diesen Eintrag trifft, wird der Schlüsselname überprüft und geändert. Anschließend wird nach einem Schlüssel gesucht, der an diesem Speicherort mit der umgeordneten GUID benannt wird:
HKLM > Software > Classes > Installer > Products
Da der Registrierungsschlüssel beschädigt ist, muss er gelöscht werden.
Lösung
Klicken Sie auf OK, um die Windows Installer-Protokolle zu erfassen. suchen Sie dann die Registrierung, die auf ARPPRoduktion zeigt und sehen Sie, welche Registrierung betroffen ist.
Hier ein Beispiel für die Jabber-Installationsprotokolle:
MSI (s) (00:68) [13:39:25:865]: Doing action: RemoveExistingProducts
Action 13:39:25: RemoveExistingProducts. Removing applications
Action start 13:39:25: RemoveExistingProducts.
RemoveExistingProducts: Application: {B63FA739-46CF-4270-B903-90F5698EDF39}, Command line: UPGRADINGPRODUCTCODE={F5C0DBF4-2D93-4A73-9AF3-E931AFF8BAF9} CLIENTPROCESSID=13016 CLIENTUILEVEL=0 REMOVE=ALL
MSI (s) (00:24) [13:39:25:880]: Unexpected or missing value (name: 'PackageName', value: '') in key 'HKLM\Software\Classes\Installer\Products\937AF36BFC6407249B30095F96E8FD93\SourceList'
CustomAction returned actual error code 1610 (note this may not be 100% accurate if translation happened inside sandbox)
MSI (s) (00:68) [13:39:25:880]: Note: 1: 1714 2: Cisco Jabber 3: 1610
MSI (c) (D8:B8) [13:39:28:589]: Doing action: setErrorUnknownError
Action 13:39:28: setErrorUnknownError.
Action start 13:39:28: setErrorUnknownError.
MSI (c) (D8:B8) [13:39:28:589]: PROPERTY CHANGE: Modifying ERROR_INSTALL property. Its current value is '0'. Its new value: '4'.
Action ended 13:39:28: setErrorUnknownError. Return value 1.
Error 1714. The older version of Cisco Jabber cannot be removed. Contact your technical support group. System Error 1610.
MSI (s) (00:68) [13:39:28:605]: Product: Cisco Jabber -- Error 1714. The older version of Cisco Jabber cannot be removed. Contact your technical support group. System Error 1610.
Klicken Sie auf dem Client-Computer auf Ausführen > Bearbeiten und navigieren Sie zu den folgenden Speicherorten:
HKLM > Software > Klassen > Installationsprogramm > Produkte > 937AF36BFC6407249B30095F96E8FD93 > SourceList
Löschen Sie die Schlüssel, starten Sie den Computer neu, und starten Sie den Installations- oder Upgrade-Prozess neu.
Anmerkung: Möglicherweise ist Administratorzugriff erforderlich, um auf die Registrierungsschlüssel auf dem Computer zugreifen zu können.